Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Ubuntu 11.04 on VMware on a Windows 7 host OS.

Wireless connection is working fine on the host OS but Ubuntu is not even recognizing it.

What can be the problem here? Why is Ubuntu not recognizing Wireless network? What can I do to be able to use Wireless network in the guest OS in vmware.

share|improve this question
First thing is to check your additional drivers and enable . – Aarti Elly Jun 30 '12 at 5:51

Your problem is that VMWare's "Automatic" default appears to be your LAN (wired) connection, instead of the wireless.

Change it explicitly from Edit --> Virtual Network Editor as shown below:

enter image description here

share|improve this answer
edit what?! i saw wht u r tryin to tell in a youtube vid, bt after extracting the contents of vmware setup i didnt find any vmnetconfg.exe Isnt tht wht u r refering to? How do i proceed? – phoenix Jun 30 '12 at 11:03
Wht VMwr vrsn? Wrksttn/Plyr? Ths apprs aftr u hv instlld VMwr, nt bfr. – izx Jun 30 '12 at 12:35

I also encountered the same problem. I also run Ubuntu 11.04 on VMware on a Windows 7 host OS. You need to get a usb dongle in order to connect to the internet because virtual machines can't expose the physical wireless cards. All of that is using a virtualization layer. So I recommend you to get a usb dongle.

share|improve this answer
Bridged networking is for more advanced networking needs such as network simulations and running servers in a guest operating system. When enabled, VMware connects to one of your installed network cards and exchanges network packets directly, circumventing your host operating system's network stack. – karel Nov 28 '14 at 6:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.