Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried using the Ubuntu Software Center but it fails. Also apt-get seems to fail as well.

I'd love some help. Thanks in advance.

share|improve this question
1  
We'll need more details to help. In particular, please edit your question to include the complete and exact text of any error messages. –  Eliah Kagan Jun 30 '12 at 5:12
add comment

2 Answers 2

Is it only the package downloading that is slow or is your Internet browsing too? Are you on a wifi network and if yes did you try with a wired connexion?

In case your problem comes from wifi I encourage you to determine what is its reference with :

lspci -v

Then look for "Network controller" or "wifi", something like that... And you'll eventually find something a bit like that:

08:00.0 Network controller: Intel Corporation WiFi Link 5100
        Subsystem: Intel Corporation WiFi Link 5100 AGN
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at c0300000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

Then you'll be able to target your question precisely and have the most accurate answers.

I personally do experience slow connexion (browsing and package downloading) and it's due to a regression in drivers for my wifi card. The following lines fix it but I need to execute them every single time i start my computer up... So i made a script of this :

sudo echo "options iwlagn 11n_disable=1">"/etc/modprobe.d/intel_11n_disable.conf"
sudo update-initramfs -u
sudo modprobe -r iwlagn && sudo modprobe iwlagn

Finally if by chance you have the same card as me here is the place where i found answers: Very slow connection on an Intel(R) WiFi Link 5100 AGN

share|improve this answer
add comment

If you're just having trouble downloading the package named "quickly", then copy and paste the following code into a terminal:

sudo apt-get update
sudo apt-get -f install

This should solve the problem. If it doesn't solve the problem, then run the following code in a terminal:

sudo dpkg --configure -a

If it still doesn't work, try to see if you have enough disk space left (1 GB or more). If you have less than 1 GB left, free up some space (or, if there is only 80 MB left, you'll have to redo the installation and accumulate your files elsewhere, even after the installation.)

If you have more than 1 GB of free space, follow the other solution posted.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.