Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

With help from this site, I was able to set up an SSHFS connection between two computers on my LAN so that one auto mounts on the other at boot time.

Everything works, but there is this annoying confirmation that comes up whenever I boot:

sshfs boot confirmation

An error occurred while mounting /home/dave/Mythbuntu.

Press S to skip mounting or M or Manual recovery

If I press S, then booting continues, and my drive is mounted as hoped, so it seems like even though I "skipped" it, maybe it tried again and succeeded later in the boot process.

I followed the instructions here to set up "if up / if down" scripts, and here is my current /etc/fstab:

sshfs#mythbuntu@192.168.0.4:/home/mythbuntu    /home/dave/Mythbuntu    fuse    auto,users,exec,uid=1000,gid=1000,allow_other,reconnect,transform_symlinks,BatchMode=yes 0 0

Although the mounting is working, this step of having to press S every time I boot is obviously kind of a hassle. How do I configure my computer so I don't have to do that, and so that my other computer will still automount?

share|improve this question
    
try unmounting and mounting it manually in a console to see what error messages it gives sudo umount ~/Mythbuntu then sudo mount ~/Mythbuntu –  solarc Jun 30 '12 at 3:16
    
@carlosz: When I remount, it says read: Connection reset by peer. –  Questioner Jun 30 '12 at 15:10
    
If you set up the scripts, please try changing the option to noauto in fstab. –  izx Jul 1 '12 at 16:46
    
@izx: That worked. Put that as an answer and you've got some rep. –  Questioner Jul 1 '12 at 17:47
    
Dave, glad to know; done. :) –  izx Jul 2 '12 at 0:51

1 Answer 1

up vote 2 down vote accepted

Since you've set up the ifup/ifdown scripts to bring SSHFS up/down with your network interface, there is no need for the system to attempt to mount it at boot via /etc/fstab; the drive still mounts because the ifup script is called after plain mount fails but before you get to your desktop.

The solution is simply to replace the auto option for SSHFS in /etc/fstab with noauto.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.