Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I think I have auto updates enabled, but I'm not sure.

Today, I lost my wireless connection icon I had in the panel and also lost my wireless network connect capabilities.

I have Windows as a back up but have found it is way too unreliable to use anymore and would love to get this working again.

Not sure why it would disappear but it is no longer auto connecting to the wireless network.

share|improve this question
    
Take a look at System>Network Connections and post a screenshot of the "Wireless tab" so we can see what your current settings are. –  jrg Dec 1 '10 at 22:39

2 Answers 2

It sounds like a common bug, it was missing on my machine too so I'm betting a bad upgrade has done something and I think it'll be fixed soon too. In the mean time you can get it back by using the following instructions:

Press Alt+F2, in the box that pops up type: killall nm-applet and press Run. This will shutdown any existing network manager icons that aren't showing up. Then

Press Alt+F2 again and this time type: nm-applet This will launch a fresh network manager applet and on my machine this worked to bring it back.

share|improve this answer

You can set NetworkManager to have a default connection. For me I need this to be ppp0.

So in order to do this, first go first into System/Preferences/Network Connections and open the "Wired" tab, and untick the "Connect Automatically" box. Next, go into "Mobile Broadband", in this case edit Verizon connection, and tick the "Connect Automatically" box.

At this point as soon as the default user logs in (assuming you have set a null password for the key ring) NetworkManager fires off this connection.

The problem arises when the connection is dropped. NetworkManager dosen't keep checking the wireless connection to see if it becomes available again. So, issue the command "killall NetworkManager". To test this disconnect from your default wireless connection and issue this command from the prompt, you'll see that NetworkManager automatically reconnects.

So, I wrote the following script to be run from CRON every 10 minutes to have networkmanager autoreconnect;

#!/bin/bash
#This script will restart network manager if it is down.
#It should be attached to a cron job to run every 15 minutes
#determine if we have a non-local IP address. If we do, returns a 1.
isup=`ifconfig | grep inet\ addr | grep -v 127.0.0.1 | wc -l`;
#if no IP, then refresh the connection.
if [ $isup -lt "1" ]; then
{
    echo "disconnected...restarting connection";
    killall NetworkManager
} 
else 
{
    exit;
}
fi

exit; 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.