Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

(I haven't used compiz in a while, and thought I'd like to try it again, hopefully in KDE)

When I try to start ccsm I get this message:

Traceback (most recent call last):   File "/usr/bin/ccsm", line 96, in <module>
    from ccm.Constants import Version, ConfFile ImportError: cannot import name ConfFile

(note: this ccsm is from the Ubuntu repositories)

What can I do to get ccsm, (,etc...?) working again?


I also tried some older ccsm I compiled a while back (not 100% sure if they where working before):


Traceback (most recent call last):
  File "/opt/compiz++/bin/ccsm", line 30, in <module>
    import pygtk
ImportError: No module named pygtk


Traceback (most recent call last):
  File "/opt/compiz++/bin/ccsm", line 30, in <module>
    import pygtk
ImportError: No module named pygtk


Traceback (most recent call last):
  File "./ccsm", line 118, in <module>
    context = compizconfig.Context(ccm.getDefaultScreen())
AttributeError: 'module' object has no attribute 'getDefaultScreen'


Traceback (most recent call last):
  File "/opt/compiz++0.9.4/bin/ccsm", line 92, in <module>
    import compizconfig
ImportError: cannot open shared object file: No such file or directory

p.s. #2 Quote:

Oops! Your question couldn't be submitted because:

users with less than 300 reputation can't create new tags. The tag 'conffile' is new. Try using an existing tag instead.

Somebody want to add 'confFile' and 'ccsm' as tags for me? or tell me why it shouldn't be added?

(and maybe, only if it's appropriate add 'ccsm++', 'libprotobuf', and/or 'pygtk', ...?)

share|improve this question
How did you install ccsm? Do you have the file /usr/lib/python2.7/dist-packages/ccm/ ? – andrewsomething Jun 29 '12 at 19:36
@andrewsomething I do have a /usr/lib/python2.7/dist-packages/ccm/ file. Looking at this file it has a ' Version = "" ' in it, maybe from a time when I had tried Compiz I installed ccsm from the repositories, the other ccsm ones were complied either by a script(/opt/compiz++), or by hand(/opt/compiz++0.9.4) a long time ago, probably not in 12.04. – Bryan Ritter Jun 29 '12 at 20:01

A possible work around: compile compiz, and use the compiled compiz's ccsm:

(don't know if all this is necessary, but it was done)

install compiz, etc... from apt-get, then install kubuntu-dev-tools ,

sudo apt-get install kubuntu-dev-tools

get this script to compile compiz,

git clone git://

(this git wasn't working when I first tried it, maybe the website was down for a bit?)

edit the scripts, kate ./scripts/build_compiz++ &, set KDE_ENABLED to "true", remove the following listed dependencies: libgnome-window-settings-dev, kde-devel, and optional: add kubuntu-dev-tools as a dependency

save, keep window open, (if you want your changes saved, the script will override your changes for the next run if you don't keep your changes when the box shows up: choose to view differences to see if it was just your changes different) (note: this may not have been said quite right)

run script as far as it will go,


it'll have some error with KDE, go back and set back KDE_ENABLED to "false"., then rerun script as far as it will go, ./scripts/build_compiz++

(optional) when finished run


then you can run


to start ccsm. as well as use the repositories compiz, or use this compiled version's compiz /opt/compiz++/bin/compiz++,...

changes made in this compiled version's ccsm apply to the repositories compiz as well. (or at least it seamed to have gone that way at some point)

NOTE: This doesn't fix the repositories ccsm.

not all settings work nicely in ccsm, if it freezes, etc... while you're figuring out what works you can: ctrl+alt+F2, and log in

compiz --replace --display :0 &

(once you've done the above one time you can use the up arrow to get it back) then ctrl+alt+F7 (or F8..F12 or whatever it is for you) to get the compiz GUI back, or if you want kwin back, run kwin --replace from kde's run menu (alt+F2)

to set up KDE to run compiz at startup, goto KDE System Settings -> Workspace Appearance -> Default Applications -> Window Manager -> Default Component -> Use a different window manager -> ... and apply....

If you want to try to make a custom compiz launcher wrapper you can try making it as ~/bin/compiz-kde-launcher and seeing if that works.

share|improve this answer
P.S. This ccsm works better with it's version of compiz than with Ubuntu's version of compiz. – Bryan Ritter Jul 4 '12 at 23:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.