Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

Since I upgraded to 12.04, I am unable to RDP to a Windows 7 server. All I can see is a pop-up that says "Uable to connect to RDP server ". I am able to RDP using Vinagre, so that rules out any issues with my router or the Windows server. As far as I can tell, there are no logs from Remmina and the Debug window shows a blank. Any one got any ideas? Thanks.

share|improve this question

marked as duplicate by Warren Hill, BuZZ-dEE, Eric Carvalho, mikewhatever, Florian Diesch Jan 31 '14 at 11:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

I too had the problem that I could connect to a Windows 7 machine and suddenly (after weeks) I got this error: Unable to connect to RDP server

In my case I deleted the entry from ~/.freerdp/known_hosts and it then worked fine.

share|improve this answer
Same goes for current debian testing, version – AndreasT Sep 12 '13 at 0:17
I had multiple entries for the same machine (because of various assigned IP's over time by DHCP. Removed them all, and voila, worked (again). Thanks! – Marcel Oct 28 '14 at 20:35
This fixed the issue for me as well. Apparently the server fingerprint changed and I needed to resync. A more verbose error would have been nice on remmina's part. – Egg Feb 26 '15 at 1:37
amaziing !!! I worked also for me. (Ubuntu 14.04 TLS) Thank you very much (+1) – Christos May 27 '15 at 19:35
Worked on Ubuntu 12.04 – luisgonzalez Oct 16 '15 at 13:31

Click Advanced tab in your Remote Desktop Preferences and choose RDP in Security drop down menu and save.

So far it works for me.

share|improve this answer
Or more generally, choose the authentication type that the server supports, NLA in my case. – phunehehe Jan 29 '14 at 5:02
Yes, this worked for me, too. – Yanick Rochon Jun 13 at 19:19

I had a similar problem, getting the "Unable to connect to RDP server" message using Remmina and Ubuntu 12.04 to a Windows 7 machine.

It worked fine for weeks and then suddenly stopped.

What fixed it was going to ~/.freerdp/certs and deleting the problem server from that file.

The next time it connected, it asked for a new cert and worked fine.

share|improve this answer
Worked like a charm. Thanks a lot !!!!!! – K.K Patel May 16 '13 at 4:21

I had this problem. Like you I had no output when running remmina on the command line and the debug window was blank. I solved this by removing the line in the file ~/.freerdp corresponding to the problem server.

share|improve this answer
filename is: ~/.freerdp/known_hosts – gare Oct 29 '13 at 13:10

I have no idea why it worked, but I started changing settings one at a time. When I edited the connection properties, I looked on the "advanced" tab and changed the security from "negotiate" to "TLS", and voila, everything works.

Strangely, "negotiate" still works on the laptop, but at least I'm back in business with my bigger monitor :)

share|improve this answer

I haven't had any files in ~/.freerdp/certs/ so I went ahead and cleared the file ~/.freerdp/known_hosts with this command:

echo "" > ~/.freerdp/known_hosts

Be careful! This will erase the entire file. I only had one entry, so it was okay.

Afterwards connecting to the server Remmina asked me to accept the servers certificate, which I did, and everything was finally back to normal. I suspect that an update of Remmina or the RDP protocoll might be the issue.

share|improve this answer
I can't imagine why Remmina can't come up with a better error message than "Unable To Connect" but your solution saved many hairs on my head!! – mehaase Sep 29 '14 at 19:15

I resolved this issue by activating the console mode for windows 2003.

Advanced ->
Protocol RDP
security = RDP
tick: Attach to console

share|improve this answer
This works fine for me, I was trying to connect to a Windows Server 2012 R2, so the last option was that I was missing. Thanks! – Alavaros Dec 17 '14 at 12:09

protected by Community Nov 26 '13 at 19:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.