Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Kubuntu 12.04 on a new computer with an Asus motherboard containing onboard NIC. The onboard NIC is enabled in BIOS. I don't happen to have a spare network card to test with. The internet connection is via a D-Link router, either wired or wireless via T-Link USB wireless adapter. The internet connection works fine for other computers on the network (2 wired and 1 wireless). I have tried multiple known-good cables and router ports with this computer. I also booting into Kubuntu 11.10 LiveCD to test there as well, same results.

This machine will not connect to the internet. On the wired connection in 12.04:

shelly@neptune:~$ sudo service networking status
networking stop/waiting
shelly@neptune:~$ sudo service networking restart
stop: Unknown instance:
networking stop/waiting
shelly@neptune:~$ ping google.com
ping: unknown host google.com
shelly@neptune:~$ ping 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_req=1 ttl=64 time=0.027 ms
64 bytes from 127.0.0.1: icmp_req=2 ttl=64 time=0.019 ms
64 bytes from 127.0.0.1: icmp_req=3 ttl=64 time=0.017 ms
64 bytes from 127.0.0.1: icmp_req=4 ttl=64 time=0.027 ms
64 bytes from 127.0.0.1: icmp_req=5 ttl=64 time=0.018 ms
64 bytes from 127.0.0.1: icmp_req=6 ttl=64 time=0.021 ms
64 bytes from 127.0.0.1: icmp_req=7 ttl=64 time=0.019 ms
^C
--- 127.0.0.1 ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 5997ms
rtt min/avg/max/mdev = 0.017/0.021/0.027/0.004 ms
shelly@neptune:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 54:04:a6:82:6b:eb
          inet6 addr: fe80::5604:a6ff:fe82:6beb/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:230 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:360 (360.0 B)  TX bytes:50506 (50.5 KB)
          Interrupt:46 Base address:0xe000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:134 errors:0 dropped:0 overruns:0 frame:0
          TX packets:134 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:10616 (10.6 KB)  TX bytes:10616 (10.6 KB)

shelly@neptune:~$ lshw -C network
WARNING: you should run this program as super-user.
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 06
       serial: 54:04:a6:82:6b:eb
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 multicast=yes port=MII speed=100Mbit/s
       resources: irq:46 ioport:e000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
shelly@neptune:~$ sudo lshw -C network
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 06
       serial: 54:04:a6:82:6b:eb
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:46 ioport:e000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff
shelly@neptune:~$ sudo service network-manager status
network-manager start/running, process 823
shelly@neptune:~$ sudo service network-manager restart
network-manager stop/waiting
network-manager start/running, process 1684
shelly@neptune:~$ lsmod | grep -i r8169
r8169                  62099  0
shelly@neptune:~$

EDIT: It turns out that instead of the detected r8169 LAN card, this motherboard uses an 8111E as discovered here. So that is the solution.

share|improve this question
add comment

4 Answers

up vote 3 down vote accepted

Let's start with a few questions to clarify your hardware configuration.

  • How is the NIC configured to operate - have you set it for Static/Manual or Automatic DHCP?
  • Are the LEDs on the NIC on/blinking?
  • What type of router/modem are you using, and are you using factory or other firmware on these devices?

A note on your printout above:

  • eth0 (which is presumably your NIC) has no IP address assigned.
share|improve this answer
    
How would I set the NIC for Automatic DHCP? This is a fresh install and I haven't touched that, but it sounds likely. The NIC LED is on. The router is a stock firmware D-Link 330, with other devices connected both wired and wireless. I noticed that eth0 has no IP address, I suspect that this is the problem. –  dotancohen Jun 29 '12 at 17:05
    
For 12.04, Click on System Settings -> Network and you will see the wired connections available. Choose Wired Connection 1 and select Options... in the bottom right corner. From there select the IPv4 Settings tab and verify that Automatic DHCP is selected. If not, select it. –  James Mullinix Jun 29 '12 at 18:02
    
This is Kubuntu, with KDE, but I was able to find the right place. For IPv4 it is set to Automatic (DHCP) and for IPv6 it is disabled. These are the same settings as another computer on the LAN that does access the internet (the one I'm typing from) so it looks right. –  dotancohen Jun 29 '12 at 20:43
    
Please post the results from dmesg | grep network, cat /var/log/kern.log | grep eth0 and cat /var/log/syslog | grep eth0 –  James Mullinix Jun 29 '12 at 23:06
    
Thank you. Here is dmesg and the kernel log and here is the syslog(Almost 1 MiB). Your assistance is much appreciated! –  dotancohen Jun 30 '12 at 8:38
add comment

why restart a service when it is stopped?

try sudo networking start

Also please configure the ip addresses (if static).

share|improve this answer
    
When I run either sudo service networking start or sudo service networking status I get the same response: networking stop/waiting. I presume that you meant to include service as their does not exist a networking command! –  dotancohen Jun 29 '12 at 17:08
    
I actually have the interfaced configured for DHCP. This is probably the problem, what might be the cause of it not getting an IP address? –  dotancohen Jun 30 '12 at 9:03
    
make sure the router is not enabled for mac filtering –  Web-E Jun 30 '12 at 9:07
    
Thank you. The router does not filter for MAC addresses. –  dotancohen Jun 30 '12 at 9:22
add comment

The problem was the lack of drivers for this motherboard's NIC in the -23 kernel. I expand on the problem more in a conclusion post to a related question.

share|improve this answer
add comment

I encountered the same problem when adjusting the sshd_config file and needing to apply the changes. Just use the good old /etc/init.d/ script and pass "restart"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.