Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to use ushare to share my music collection with my Xbox.

I am using the following command line:

ushare -i wlan0 -x -c ~/Music/

But I get the following as an error:

Interface eth0 is down.
Recheck uShare's configuration and try again !
ioctl: Cannot assign requested address

I have an ethernet adapter in my PC but it's not connected. How can I get it to be happy with wlan0?

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

Simple answer this one (i hope):

ushare needs to run as root (maybe not, see commments)

  1. Rather than starting it with the command you've mentioned, try doing this:

    sudo service ushare start
    

    after you've set all of the options in the configuration file.

    The configuration the error message is mentioning is located at /etc/ushare.conf (or perhaps /etc/ushare/ushare.conf I'm not sure). In it, you'll be able to set the network interface permanently.

    These are the relevant bits:

    # Interface to listen to (default is eth0).
    # Ex : USHARE_IFACE=eth1
    USHARE_IFACE=wlan0
    
    
    # Directories to be shared (space or CSV list).
    # Ex: USHARE_DIR=/dir1,/dir2
    USHARE_DIR=/home/rich/Music
    

    Two things additionally: I don't know what -x and -c do, i hope there's an option for it in the configuration. Secondly, the directories in USHARE_DIR might have to be absolute path (i.e. not ~ but /home/rich or whatever your user name is).

  2. If all of this doesn't work properly, or if you just don't want to try it out, you can also just run your command prepending sudo.

Note: my sources for ushare needing to be ran as root are all either concerning different Linux distribution or they are rather old. If this is no longer the case, please let me know - I don't want to send anybody down the wrong path.

share|improve this answer
    
uShare runs fine in the user context. No need to be root. +1 for pointing to ushare.conf. Once the config is set up jus run ushare -c/share with optional parameter -x for XBox. See ushare.geexbox.org/#Usage –  Takkat Dec 2 '10 at 8:52
2  
-x is for saying "behave badly so that you work with the Xbox" and -c tells it which folder to share... –  Rich Dec 2 '10 at 15:59
1  
To get my Xbox360 to see the uShare, I had to do the above and also set USHARE_ENABLE_XBOX=yes but USHARE_ENABLE_DLNA to blank (not 'yes' as some tutorials suggest). FYI: you can get to a GUI wizard with sudo dpkg-reconfigure ushare –  Robert Corvus Feb 16 '12 at 5:41
add comment

you have to manually change the configuration

sudo gedit /etc/ushare.conf

from

USHARE_IFACE=eth0

to

USHARE_IFACE=wlan0
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.