Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

since I have some problems with my download speed under ubuntu (see my other question) I installed ndiswrapper to load windows driver for my wifi card. Unfortunatly it didn't worked very well so I deinstalled ndiswrapper. But now in network-manager-applet the option to connect wifi is also gone.

How can I load the standard wifi driver or even better how can i activate the wireless backports driver so that it works with network-manager-applet?

I found an advice via google to use sudo modprobe wl but this gives the message FATAL: Module wl not found.

share|improve this question

2 Answers 2

Firstly, make sure your hardware's driver isn't blacklisted in /etc/modprobe.d/*. It would appear with "blacklist " prepended on a line, e.g., "blacklist wl" (if your driver is wl). Secondly, installing linux-backports-modules-wireless-maverick-generic should suffice after a reboot (provided that the appropriate driver isn't blacklisted and that you're using 10.10/Maverick).

share|improve this answer
    
i don't find something like wl blacklisted in the /etc/modprobe.d/ folder. but i'm not sure if wl is exactly the name of my driver since i found the advice (modproble wl in a forum). How can i recognize what's the name of my driver i used before? I installed the backports drivers, but after a reboot there is now wifi device in iwconfig. –  NES Dec 1 '10 at 21:39
    
update: i found the module name of my wifi and now it works as it should. the only limitation is i'm using not the latest kernel at the moment. cause i switched back. how can i verify which driver the card use (backports? version) so that i can check if i use the right one under the latest kernel? –  NES Dec 1 '10 at 21:46
up vote 1 down vote accepted

the solution was to use modprobe with the right modulename so if anyone has the problem use:

sudo modprobe yourmodulenameforyourwificard
share|improve this answer
    
You should mark this answer as accepted if it solved the problem. (Yes, even though it's your own, thats quite okay) –  Stefano Palazzo Dec 2 '10 at 13:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.