Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am trying to start my webhttrack on ubuntu 12.04 precise pangolin but all i get is the opening screen. When i press any button on the page it gives me the following errors:

Oops! Google Chrome could not connect to barney:8081
Suggestions:
Try reloading: barney:­8081/­server/­step2.­html

i tried to run from a terminal window and get the output here:

webhttrack
/usr/bin/webhttrack(4405:( launching /usr/bin/x-www-browser
/usr/bin/webhttrack(4405:( spawning regular browser..
Created new window in existing browser session.
/usr/bin/webhttrack(4405:( browser exited
/usr/bin/webhttrack: line 167:  4422 Killed                 
${BINPATH}/htsserver "${DISTPATH}/" path "${HOME}/websites" lang "${LANGN}"
$@

If anyone can help me i appreciate it.

share|improve this question
    
Try running http://yourHostname:8080/server/index.html in your browser. –  atenz Jun 29 '12 at 15:20
    
Your hostname means run hostname in terminal , copy that name and replace that in yourhostname in above address. –  atenz Jun 30 '12 at 2:31

4 Answers 4

up vote 1 down vote accepted

I had the same bug.

It seems that after editing

/etc/apache2/ports.conf

and commenting all the lines like :

#Listen 8080
#NameVirtualHost *:8080

and :

sudo service apache2 restart

it works.

I don't have the time to play around and investigate the bug more than that

PS: Before that I also installed the last quantal version but it didn't change a thing

share|improve this answer
1  
hum, bug again it seems the problem is with using chrome, using firefox is ok –  abuhurayra Aug 28 '12 at 15:25

You can use firefox instead of chrome. Interestingly, you don't even need to use firefox as long as you open it. (Would be interested to know why this could be.) My default browser is chrome and webhtttrack won't open there unless firefox is open as well.

share|improve this answer
1  
same here and your solution works great!! –  tigerjack89 Nov 6 '14 at 13:23

For me the problem was using chrome/chromium.

As described here, i hardcoded firefox in the webhttrack script:

sudo vim /usr/bin/webhttrack

and modified the first line into:

BROWSEREXE="firefox"

works like a charm after!

share|improve this answer
    
even after modified this line, it continues to open chrome :S. For me, the only way to get it work is to have both firefox and chrome opened. –  tigerjack89 Nov 6 '14 at 13:23

Sometimes it will still want to use Chrome or even another browser. I used this trick and it worked good for me.

sudo gedit /usr/bin/webhttrack

Then there I search the line:

BROWSEREXE=

and change it to

BROWSEREXE="firefox"

Then I search for:

SRCHBROWSEREXE="x-www-browser www-browser iceape mozilla firefox icecat iceweasel abrowser firebird galeon konqueror opera chrome chromium chromium-browser netscape"

and just comment the line with #:

#SRCHBROWSEREXE="x-www-browser www-browser iceape mozilla firefox icecat iceweasel abrowser firebird galeon konqueror opera chrome chromium chromium-browser netscape"

Now just save and run, and it will open the browser of your choice.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.