Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I started installing the Humble Indie Bundle 5 games the software center stopped working and now I get this error.

Packages cannot be installed or removed, click here to repair. Which fails and gives these results.

installArchives() failed: (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 255502 files and directories currently installed.)
Unpacking libqtcore4:i386 (from .../libqtcore4_4%3a4.8.1-0ubuntu4.1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libqtcore4_4%3a4.8.1-0ubuntu4.1_i386.deb (--unpack):
 conffile './etc/xdg/Trolltech.conf' is not in sync with other instances of the same package
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 /var/cache/apt/archives/libqtcore4_4%3a4.8.1-0ubuntu4.1_i386.deb
Error in function: 
dpkg: dependency problems prevent configuration of libqtgui4:i386:
 libqtgui4:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
dpkg: error processing libqtgui4:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql:i386:
 libqt4-sql:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
dpkg: error processing libqt4-sql:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ia32-libs-multiarch:i386:
 ia32-libs-multiarch:i386 depends on libqt4-sql; however:
  Package libqt4-sql:i386 is not configured yet.
 ia32-libs-multiarch:i386 depends on libqtcore4; however:
  Package libqtcore4:i386 is not installed.
 ia32-libs-multiarch:i386 depends on libqtgui4; however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing ia32-libs-multiarch:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-declarative:i386:
 libqt4-declarative:i386 depends on libqt4-sql (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-sql:i386 is not configured yet.
 libqt4-declarative:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
 libqt4-declarative:i386 depends on libqtgui4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqt4-declarative:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-svg:i386:
 libqt4-svg:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
 libqt4-svg:i386 depends on libqtgui4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqt4-svg:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-network:i386:
 libqt4-network:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
dpkg: error processing libqt4-network:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql-mysql:i386:
 libqt4-sql-mysql:i386 depends on libqt4-sql (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-sql:i386 is not configured yet.
 libqt4-sql-mysql:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
dpkg: error processing libqt4-sql-mysql:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-script:i386:
 libqt4-script:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
dpkg: error processing libqt4-script:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-dbus:i386:
 libqt4-dbus:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
dpkg: error processing libqt4-dbus:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl:i386:
 libqt4-opengl:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
 libqt4-opengl:i386 depends on libqtgui4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqt4-opengl:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqtwebkit4:i386:
 libqtwebkit4:i386 depends on libqt4-network (>= 4:4.8.0~); however:
  Package libqt4-network:i386 is not configured yet.
 libqtwebkit4:i386 depends on libqtcore4 (>= 4:4.8.0~); however:
  Package libqtcore4:i386 is not installed.
 libqtwebkit4:i386 depends on libqtgui4 (>= 4:4.8.0); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqtwebkit4:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-designer:i386:
 libqt4-designer:i386 depends on libqt4-script (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-script:i386 is not configured yet.
 libqt4-designer:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
 libqt4-designer:i386 depends on libqtgui4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqt4-designer:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lonesurvivor-bin:i386:
 lonesurvivor-bin:i386 depends on ia32-libs-multiarch; however:
  Package ia32-libs-multiarch:i386 is not configured yet.
dpkg: error processing lonesurvivor-bin:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lonesurvivor:
 lonesurvivor depends on lonesurvivor-bin (= 1.11d-0ubuntu5); however:
  Package lonesurvivor-bin is not installed.
  Package lonesurvivor-bin:i386 is not configured yet.
dpkg: error processing lonesurvivor (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-scripttools:i386:
 libqt4-scripttools:i386 depends on libqt4-script (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-script:i386 is not configured yet.
 libqt4-scripttools:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
 libqt4-scripttools:i386 depends on libqtgui4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqt4-scripttools:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-qt3support:i386:
 libqt4-qt3support:i386 depends on libqt4-designer (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-designer:i386 is not configured yet.
 libqt4-qt3support:i386 depends on libqt4-network (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-network:i386 is not configured yet.
 libqt4-qt3support:i386 depends on libqt4-sql (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-sql:i386 is not configured yet.
 libqt4-qt3support:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
 libqt4-qt3support:i386 depends on libqtgui4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqt4-qt3support:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-xml:i386:
 libqt4-xml:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
dpkg: error processing libqt4-xml:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-test:i386:
 libqt4-test:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
dpkg: error processing libqt4-test:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-xmlpatterns:i386:
 libqt4-xmlpatterns:i386 depends on libqt4-network (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-network:i386 is not configured yet.
 libqt4-xmlpatterns:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtcore4:i386 is not installed.
dpkg: error processing libqt4-xmlpatterns:i386 (--configure):
 dependency problems - leaving unconfigured

I couldn't get the apt-get update or upgrade to work either so I shut off the repositories and updated / upgraded one at a time without any problems. But that didn't fix the Software Center.

Help would be greatly appreciated.

ADDED UPDATE

I've tried to install aptitude using dpkg but can't. I have also tried

sudo apt-get dist-upgrade
sudo apt-get autoremove
sudo dpkg --configure -a --force-all

and the -f options.

Though I believe this is where my problem is originating:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libqtcore4:i386
The following NEW packages will be installed:
  libqtcore4:i386
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/2,061 kB of archives.
After this operation, 9,041 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 255526 files and directories currently installed.)
Unpacking libqtcore4:i386 (from .../libqtcore4_4%3a4.8.1-0ubuntu4.1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libqtcore4_4%3a4.8.1-0ubuntu4.1_i386.deb (--unpack):
 conffile './etc/xdg/Trolltech.conf' is not in sync with other instances of the same package
Errors were encountered while processing:
 /var/cache/apt/archives/libqtcore4_4%3a4.8.1-0ubuntu4.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I hope this helps narrow it down some.

SECOND UPDATE

sudo apt-get --reinstall install software-center -f

The following packages have unmet dependencies:
 ia32-libs-multiarch:i386 : Depends: libqtcore4:i386 but it is not going to be installed
 libqt4-dbus:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-declarative:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-designer:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-network:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-opengl:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-qt3support:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-script:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-scripttools:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-sql:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-sql-mysql:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-svg:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-test:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-xml:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqt4-xmlpatterns:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqtgui4:i386 : Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.1) but it is not going to be installed
 libqtwebkit4:i386 : Depends: libqtcore4:i386 (>= 4:4.8.0~) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

sudo apt-get -f install doesn't work either.

Complete output of terminal for step 5 of this procedure can be found here:
http://paste.ubuntu.com/1066192/

share|improve this question

closed as too localized by Jorge Castro, Ringtail, hhlp, ajmitch, fossfreedom Nov 21 '12 at 22:53

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

2 Answers 2

Fixed it myself. Took about 8 hours of playing around.

I went into the software center package lists and deleted the info for Lone Survivor and Psychonaughts (the problems) and did sudo apt-get -f install. Then I re-installed the libcore4 files.

But now that it is fixed I don't even want to try and download the Humble Bundle 5 again.

share|improve this answer
    
Hmm. Sorry to hear that -- I haven't had serious issues with any of the humble bundle games, once software center finally synced up. –  belacqua Nov 21 '12 at 17:57
add comment

Run this command: sudo aptitude reinstall software-center

share|improve this answer
    
I don't have aptitude installed. I tried to install the .deb using dpkg and it says it depends on libcore4i386 which is my problem. –  Colin Jun 29 '12 at 14:24
    
@Colin You can use sudo apt-get --reinstall install software-center instead. –  Eliah Kagan Jun 29 '12 at 14:28
    
It doesn't work, I posted the error above. –  Colin Jun 29 '12 at 14:33
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.