Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've bought VMware Workstation 8 just today. After the installation I launched it and the application noticed me that "several modules must be compiled and loaded into the running kernel".

During the process, VMware noticed me that was impossible to configure Virtual Network Devices and at the end, was impossible to start the services.

The last message said that further information could be found at this address: /tmp/vmware-root-975001794/modconfig-22789.log

So, I've pasted the content of the log message here.

Can you help me or, rather, you suggest to wait for future updates of Ubuntu? My desktop environment is Unity.

share|improve this question
2  
Please remember to accept/upvote the best answer to your question (tick/check mark on the left). This way, the question is marked as "answered" and future readers can refer to it knowing the solution works. Thank you...:) –  izx Jul 8 '12 at 4:58
add comment

4 Answers 4

A simple patch needs to be applied to the module sources

The patch is described and available on this page, but the version in there needs to be changed to 8.0.4 to apply successfully.

Here's how:

To download and apply the patch,

  • Open a terminal and type:

    mkdir vmw_patch && cd vmw_patch
    wget -O- http://weltall.heliohost.org/wordpress/wp-content/uploads/2012/01/vmware802fixlinux320.tar.gz | tar -xz
    sed -i -e 's/8.0.2/8.0.4/g' patch-modules_3.2.0.sh 
    ./patch-modules_3.2.0.sh
    
  • That should compile the modules without any errors.

Explanation: wget downloads the patch, and tar extracts it without actually saving the downloaded file. sed updates 8.0.2 to 8.0.4 in the patching script so that it will run.

share|improve this answer
add comment

When following izx's instructions, if you have VMware Player rather than VMware Workstation, you'll use this command (instead of the sed ... command given there):

sed -i -e 's/4.0.2/4.0.4/g' patch-modules_3.2.0.sh
share|improve this answer
add comment

Thank you both very much for the solution. The only thing I noticed was that I needed to install "patch" with:

sudo apt-get install patch

I'm not sure if this is present on the default install, but I didn't have it for whatever reason. Either way, thank you both so much!

share|improve this answer
add comment

izx's answer worked for me with two exceptions:

  1. I had to run the script as root.
  2. Since I had already applied the same patch earlier when I upgraded from 8.02 to 8.03, I had to remove the old patch flag file and re-run the patch:

    sudo rm /usr/lib/vmware/modules/source/.patched
    sudo ./patch-modules_3.2.0.sh
    

You can find a detailed guide including the above at this blog post.

share|improve this answer
add comment

protected by RolandiXor Aug 8 '12 at 3:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.