Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Suspend works OK in Windows XP on this computer, but not in Ubuntu 12.04.

share|improve this question

I had your symptoms on a HP 2000 laptop, without the Windows. In my case, it used to work before the upgrade to 12.04.

My solution:

  1. Disable the Nvidia proprietary drivers. In my case, the one with updates wouldn't load and the original was "active". I removed it, leaving no Nvidia drivers at all.

  2. Start Ubuntu in 2D mode. I think I have tried Ubuntu, Gnome, Gnome Classic, and Gnome Classic (no effects). One of them may also work, but I'm sure '2D' does.

That's it. I can suspend and resume now. Hope this helps someone.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.