Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

powertop shows desktopcouch and gwibber-service are not-inconsiderable power-users. I don't use gwibber or Ubuntu One, so can I safely kill these processes? If so, how could I stop them starting up, especially if my laptop is on battery power?

share|improve this question

4 Answers 4

up vote 3 down vote accepted

If you don't use them, you could uninstall them both. DesktopCouch isn't used for much yet. I just checked my database, and it's only really used for Gwibber and Evolution's contacts (and an experimental build of Caffeine).

share|improve this answer
    
DesktopCouch is also used for Tomboy notes. –  Hamish Downer Aug 7 '10 at 12:33
1  
Tomboy doesn't use couch, when you connect it to Ubuntu One it uses the Snowy API that upstream tomboy uses. –  Jorge Castro Aug 7 '10 at 13:57
    
This is what I've ended up doing. –  richq Aug 7 '10 at 20:25

Open the System menu, go to Preferences and select Startup Applications. You can scroll through the list and deselect the two "Ubuntu One" entries. You might also want to turn off the Bluetooth service if you don't use that.

share|improve this answer
    
Yep, I already had all of those turned off. Thanks anyway. –  richq Aug 7 '10 at 20:16

To disable gwibber-service, instead of removing the package you could just disable the autostart service:

echo "Hidden=true" | sudo tee -a /etc/xdg/autostart/gwibber.desktop

source: http://geekvigarista.com/os/linux/ubuntu-linux/removendo-o-gwibber-e-desabilitando-o-gwibber-service-no-ubuntu

share|improve this answer

I installed Ubuntu 10.04 on an x86-64 laptop and disabled Ubuntu One already from the "Startup applications". Yet I still have desktop couch processes running:


1886 ?        S      0:00 /bin/sh -e /usr/bin/couchdb -n -a \"/etc/couchdb/default.ini\" -a \"/etc/xdg/desktop-couch/compulsory-auth.ini\" -a \"/home/wirawan/.config/desktop-co
 1914 ?        S      0:00  \_ /bin/sh -e /usr/bin/couchdb -n -a \"/etc/couchdb/default.ini\" -a \"/etc/xdg/desktop-couch/compulsory-auth.ini\" -a \"/home/wirawan/.config/deskto
 1915 ?        Sl     6:38      \_ /usr/lib/erlang/erts-5.7.4/bin/beam.smp -Bd -K true -- -root /usr/lib/erlang -progname erl -- -home /home/wirawan -- -noshell -noinput -smp au
 1937 ?        Ss     0:01          \_ heart -pid 1915 -ht 11
 1790 ?        S      7:20 /usr/bin/python /usr/lib/desktopcouch/desktopcouch-service
 1976 ?        SN     8:00  \_ /usr/bin/python /usr/lib/desktopcouch/desktopcouch-service

Anyone having idea to disable this completely without uninstalling desktop couch stuff?

share|improve this answer
    
It looks like gwibber service is not disabled in my system. I think this one causes couchdb service to be invoked. How to disable that too? –  wirawan Dec 14 '10 at 16:28
    
(comment deleted. It's the same as above. Sorry for typing the same thing twice.) –  wirawan Dec 14 '10 at 16:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.