Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 10.10 and i like it. But since yesterday i have a problem with the downloadspeed via my router. The normal speed is over 10MBit/s and i reached this speed always with Ubuntu. Since yesterday is have less than 1MBit/s. The Windows PC in the same wifi network still reaches over 10Mbit/s.

Don't know what happened to my Ubuntu installation. Anyone can give me some help to fix the problem?

Update:

  1. i tried to install ndiswrapper but it didn't work with the original windows driver from the manufacturer of my wlancard. then i deinstalled. now at the moment the state is that ubuntu doesn't recognize the wlan card since it has deleted the standart driver when i activated ndiswrapper. I need an advice to activate the original driver (sudo modprobe wl doesn't work, Fatal: module wl not found)

  2. now i managed to reload the original driver via modprobe wifimodulename Wifi works again.

changed issue: I now use the backport wireless drivers and i have the full wifi speed now again but sometimes after a time i use the wifi connection the speed again decreases to under 1MBit or even more bad to under 0.1MBit. When i deactivate Wifi connections via network-manager-applet and reactivate it, it again has the full speed.

share|improve this question
    
Have you tried to download the same things (i.e. from the same sites) concurrently from both computers? –  Pavlos G. Dec 1 '10 at 19:04
    
don't you mean successively? –  Stefano Palazzo Dec 1 '10 at 19:13
    
yes, the same files and i also tried several speedtests. The WifiCard always worked fine. it's merkwürdig curious, sometimes when i restart ubuntu, i have the full speed that my provider declares and when i start a download i holds the speed for some seconds and then decreases from over 10MBit to under 1MBit. Under Windows with the same files i can download with my standart speed. I supposed that this problem is caused by a update i.e. kernel update. But since i'm a relative beginner with Unix Linux i have no idea how i can figure out what's the reason for this problem. –  NES Dec 1 '10 at 19:26
    
Can you try booting from a Live CD and reporting the speed test results? –  user5260 Dec 1 '10 at 21:01
    
Hi, i tried the speedtests from the same pc via the ethernet controller and it works in the standart speed. so i must be the wireless driver. I have now installed ndiswrapper and the windows driver but this doesn't work. The problem now is that the wireless driver is gone. Via the network-manager-applet there is just the ethernet option. Can someone give me advice to get back to the standart drivers or better to the backports wirless drivers. Perhaps you would like to see my other question (see my profile) to this? –  NES Dec 1 '10 at 21:11

3 Answers 3

I have found that wireless is always slower than the wire for one thing. Another factor is other computers using the wireless connection at the same time. Wireless routers have trouble supporting more than a few concurrent connections at the same time. The first thing I would do is log into the router and look at the DHCP clients to see who is connected. You may unwittingly be giving free internet to a neighbor.

share|improve this answer

How does your Wifi connection strength indication look when you have the problem?

It could be the computer is in an unfavourable spot, and the wifi signal isn't good enough, in which case, the wifi driver will throttle your connection down to, perhaps, 1mbit/s to decrease the rate of errors.

Try moving all of the devices a bit, the connection indicator will take a fair few seconds to catch up. Also, have a look at the connection speed: Mine is Speed: 36 Mb/s at the moment (not the full 54, because the connection isn't that good). So see this,

  • right click on the wifi indicator and select alt text Connection Information.

It should be between ~20 and 54 (perhaps more) Mb/s. Anything less means you have a connection that needs to be looked at.

Hope this is it.

share|improve this answer
    
hi Stefan, the both PCs linux and windows stand next to each other, so i think that isn't the problem. At the moment i have the problem that the standart wireless driver i used is gone after i installed and deinstalled ndiswrapper. i used sudo modprobe wl. but it gives me the message Fatal: Module wl not found. so i need an advice to reactivate the standart wireless driver. –  NES Dec 1 '10 at 21:25
    
In that case this is a completely different issue. You should either update your question accordingly, or incorporate this question into your other question askubuntu.com/questions/15764 - i didn't realise you had asked both –  Stefano Palazzo Dec 1 '10 at 21:30
    
hi stefan, the second problem (the other question) was a consequence from this issue. that problem was solved then by activating the kernel module for the wireless backports. i updated the question meanwhile. since the issue shows a decently changed behaviour with the backport drivers. please see my updated question. –  NES Dec 2 '10 at 9:42
up vote 0 down vote accepted

The solution for me was to install the backport wireless drivers, have a look a this http://wiki.ubuntuusers.de/WLAN/Linux-backports-modules

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.