Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All in the title ,
Hello askubuntu , there is my problem :
when i try to access my apache website from my IP address i got the router homepage,
please help

i'm using UBUNTU 12.04 LTS , Apache2 , and my router is Sagem F@st 1704

share|improve this question
1  
You mean when trying to access from outside the network using external ip address..? –  user73595 Jun 28 '12 at 19:06
    
yes exactly ! –  Mools Gang Jun 28 '12 at 19:13
    
disable remote administration on your router, and forward port 80 to your computer. you router's monopolizing port 80. –  Thomas W. Jun 28 '12 at 20:25
    
i could'nt find where it is , there is my router page i.stack.imgur.com/1VkxG.png –  Mools Gang Jun 28 '12 at 20:50

1 Answer 1

up vote 1 down vote accepted

I assume you are trying to access the webpage using your external IP address, and not your LAN address (such as 192.168.x.x).

By default, the router will not pass anything to the LAN that it has not specifically been told to allow. It should have a place to allow certain ports to be passed through to the computers listening for that port, and often has easy configuration for common ports such as HTTP, SSH, FTP, etc. Web pages normally listen on port 80, by default, although this can be changed (but would require a special URL specifying the port).

The feature to allow connections to local computers is called "Port Forwarding". It is router specific, so you need to connect to your router and either find it, or look through the manual.

It's best not to allow all requests to be passed, but to only enable specific protocols such as HTTP on port 80.

If you're completely new to this, you might find this article helpful.

Edit - How to find the admin settings

In order to change the settings rather than simply viewing them, you must log in as "admin". According to the manual, the way to do this is to enter the ip address in your browser (192.168.1.1), and log in as "admin", with the default password "admin". But if this router is is from your ISP, they may have changed the password. If this is the case, you may need to search forums for your ISP to find the password, unless they will tell you what it is (good luck with that - they may disallow servers).

share|improve this answer
    
My server was configured ans connected to internet last mounth , and everything was going okay , until i changed my router , –  Mools Gang Jun 28 '12 at 20:30
    
when i changed my router i couldn't find out where is the port forwarding stuff in it's page , i'll sent you a picture of my router page –  Mools Gang Jun 28 '12 at 20:32
    
there is my router homepage , i coudn't find a way out ther is a picture of my router page [link]i.stack.imgur.com/1VkxG.png –  Mools Gang Jun 28 '12 at 20:37
    
Well, it's probably not going to be on the home page. I suggest trying the other pages shown on the left, such as "WAN", etc. I'd need to look through the manual to really know for sure, but you should do more investigation before I would want to do that. –  Marty Fried Jun 28 '12 at 20:51
    
the pages on he left are contenig statistics of connecion there nothing to edit , except this one : i.stack.imgur.com/TYX94.png –  Mools Gang Jun 28 '12 at 20:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.