Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Launchpad failed to build after “quickly submitubuntu”

I created an app for the Ubuntu App Showdown and I'm trying to upload it to the Ubuntu Software Center. My steps are:

  1. quickly submitubuntu
  2. Go to the app page Ubuntu App Developer website and upload the package .tar.gz created by quickly in the step #1.
  3. Then I receive this email: http://paste.ubuntu.com/1064804/

It says: "State: Failed to build". I tried to add the libglib2.0-bin dependence, but I get the same result.

Any idea, please? Will be the app submit with this error? Thanks in advance!

share|improve this question

marked as duplicate by David Planella, andrewsomething, ajmitch, htorque, jokerdino Aug 19 '12 at 15:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

2 Answers 2

up vote 1 down vote accepted

Did you add libglib2.0-bin to the "Depends" in the binary section of debian/control, or to the Build-Depends in the source section?

It needs to be in the source (top) section in Build-Depends

share|improve this answer
    
Thanks. That is the problem, but quickly overwrite that file all times. –  costales Jun 29 '12 at 14:34
add comment

Reading the answer from the question you referenced this is a bug in quickly that has not been fixed. Read a bit further down and do the submitubuntu steps manually as noted in the accepted answer.

share|improve this answer
    
Thanks, but the answer not works for me. paste.ubuntu.com/1066120 ('function' user replies with the same error). –  costales Jun 29 '12 at 14:35
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.