Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Nothing happens when I click Desura, clicking force update works but that does not fix the problem.

EDIT: I know am getting this error: Details: Failed to execute child process "/home/neil/Downloads/desura" (Permission denied)

share|improve this question

2 Answers 2

Usually Failed to execute child process with (Permission denied) means that the program being executed doesn't have execute permissions set for it.

By default, files downloaded on Ubuntu do not have execute permissions enabled. One of the reasons for this is to help protect you from malicious programs (or non-malicious programs that you just don't want to run by accident).

If you're sure /home/neil/Downloads/desura is safe for you to run, then you can enable execute permissions for it.

Command Line Way

Run this command in a terminal:

chmod +x /home/neil/Downloads/desura

You probably already own the file, so you should not need to run that command with sudo.

Graphical Way

In Nautilus (the file browser), find desura in your Downloads folder, and right-click on it. Click Properties.

Nautilus file Properties window showing check box for Execute permission

Click the Permissions tab, and check the box labeled Allow executing file as program. Then click Close.

share|improve this answer

check the ownership of the file.

ls -la <file-name>

You should be the owner of the file and have execute permission

share|improve this answer
1  
Right now, your answer looks like it's saying ls will itself change ownership on the file (which is not the case). You may want to edit your answer to clarify exactly what you suggest the OP should do. –  Eliah Kagan Jun 29 '12 at 10:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.