Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I access my Internet connection through through a proxy server. All I need to enter is HTTP address and port. Where can I enter these for system-wide settings?

Note: this question and answers apply only to the default Ubuntu Desktop environment, known as Unity. These steps will not work for Xubuntu, Lubuntu, Kubuntu or other variants.

share|improve this question
    
@izx, any pointers to how to achieve the same on Xubuntu? –  Majid Fouladpour Jun 28 '12 at 6:32
    
@MajidFouladpour, see here :-) –  izx Jun 28 '12 at 6:52
add comment

3 Answers

For 10.04

System > Preferences > Network Proxy, you setup the proxy and click on Apply System-Wide. If your proxy need authentication click on Details, click on use authentication and type your username and password for the proxy and only after that click on Apply System-Wide. After that, you will need to restart the applications that are already running.

If you need a username and password to login see here:

share|improve this answer
add comment

For 12.04:

Well, there is already an answer very similar to what I was going to post, but I will post mine too just to make it more clear.

From Ubuntu 11.04 onwards, it's known fact that there have been many changes to Network Settings in Ubuntu. Of course, many people who wanted proxy authentication (like me) had to work a little hard to get it. So, this new short guide is for those who need Proxy settings (with/ without authentication).

Note: In the Screenshots below my Ubuntu is a little bit customized, so the icons may look different in your system.

First of all, either click on the launcher icon (or press super) and it opens Unity panel. Now search for Network, and it will show you some results like this: Searching for network in Unity Panel

Select the first one that says Network.

It will open the Network settings window.

The same can also be opened by searching for System Settings in the Unity and clicking on Network in it like it's shown below: Network Settings in System Settings

After the Network Settings window pops up, click on Network Proxy on left like it's shown here: Go to the Manual Proxy Settings

Now, select Manual on the right and enter the proxy address for each type of server. Let's say that I have a Proxy server at address 172.27.1.1 at port number 5321. The proxy settings would look like this: Manual Proxy settings for some address

Now, if you need authentication to access the proxy, type your username and password as shown below: Username and Password in Proxy

Lastly, click on Apply System Wide to apply the settings system wide. This will pop up a one or two authentication windows like shown below. Authentication to change proxy settings

Enter your password to set the settings and that's it... the System Proxy settings are all set and your Ubuntu is ready to use them!!

share|improve this answer
    
This is a real Ubuntu 12.x PITA for me. Twice a day I have to open up this "network" dialog, navigate via the mouse from "wired" to "proxy", and set my proxy settings to/from manual to no proxy (for my work laptop). It wouldn't be so bad if the network applet popped up with "network proxy" already with focus, but as it stands, I don't even think you can "tab" through to get to the proxy settings. (Using laptop mice-nipples are like friggin' surgery.) There has got to be a better way: I just want to open a proxy setting dialog, or simply set this via terminal+gconf or something... –  michael_n Feb 26 '13 at 20:34
1  
I just found the answer to my previous comment => see askubuntu.com/questions/150210/… => if you have "none" and "manual" predefined, simply run: gsettings set org.gnome.system.proxy mode 'manual' or gsettings set org.gnome.system.proxy mode 'none' , but you can also set specific host/port proxy settings there too (less of an issue for me though) –  michael_n Feb 26 '13 at 20:44
add comment

Proxy settings in Ubuntu 12.04

Press super and type "network". Your first hit should be the network settings pictured below.

Enter your proxy settings (manual or automatic instead of "none") and click "Apply system wide". Restart any applications already running.

enter image description here

enter image description here

enter image description here

Applying changes system-wide requires administrator privileges:

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.