Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Ubuntu 12.04 installation has an input problem resulting preventing me from clicking near the top of the screen. That is, there is an unclickable area, circa 60 pixels high and stretching all the way across the screen. I will ask about this in a later question.

For now, I would just like to be able to connect to the internet, given this limitation. I am able to access the network connections application by hitting the super key and typing "network connections". There is a LAN and a wireless network available.

The network icon in the bar at the top of the screen shows an empty wedge, which I suppose means that wireless is off. I've attached the cable for the Ethernet connection, but it does not seem to have connected automatically. How can I figure out what's going on?

(I'll happily edit in the output of any relevant terminal commands.)

Thank you.

Edited to add command outputs:

ben@ben-laptop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1e:68:cb:cc:3e  
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21e:68ff:fecb:cc3e/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:712 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5243 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:144145 (144.1 KB)  TX bytes:267015 (267.0 KB)
          Interrupt:48 Base address:0x4000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4464 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4464 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:391786 (391.7 KB)  TX bytes:391786 (391.7 KB)

wlan0     Link encap:Ethernet  HWaddr 00:16:ea:bd:5a:5a  
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

ben@ben-laptop:~$ lspci | grep -i 'Network'
02:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection

ben@ben-laptop:~$ ping -c 5 www.google.com
ping: unknown host www.google.com

The wireless network seems to be available:

    ben@ben-laptop:~$ sudo iwlist scan
[sudo] password for ben: 
lo        Interface doesn't support scanning.

vboxnet0  Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:01:3B:AE:38:9A
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=27/70  Signal level=-83 dBm  
                    Encryption key:on
                    ESSID:"BTHub3-XPMM"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000133c5ccc08
                    Extra: Last beacon: 3020ms ago
                    IE: Unknown: 000B4254487562332D58504D4D
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030106
                    IE: Unknown: 2A0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32043048606C
                    IE: Unknown: 2D1AAC011BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1606080000000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0101
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F20201018C0003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C33AC011BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3406080000000000000000000000000000000000000000
                    IE: Unknown: DD0900037F01010000FF7F

eth0      Interface doesn't support scanning.

Final Note:

I restarted the system and the internet appears to work, via wifi, so the problem is solved, for now.

share|improve this question
    
could you please post the output of the commands ifconfig and lspci | grep -i 'Network' –  Daniel Jun 28 '12 at 15:36
    
@Daniel Thanks. I've now done that. –  Ben Jun 28 '12 at 15:51
    
okay please type ping -c 5 www.google.com to see if you can send and recieve packages from the internet. Cause it seems you are connected. –  Daniel Jun 28 '12 at 15:54
    
@Daniel Thanks. I've added the result of the ping below the command outputs. –  Ben Jun 28 '12 at 16:09

3 Answers 3

This answer should help you: How do I connect to a WPA wifi network using the command line? the "ssid name" is the name of the network given in iwlist so for you it would be "BTHub3-XPMM"

hope this helps

share|improve this answer

In the case if its H/W problem just try manually to resize the desktop window. If not possible n u want it to use thro' terminal and u have firefox installed on ur system then directly in terminal type "firefox" it will open the firefox for u.

share|improve this answer
    
Also using system settings just allocate keyboard shortcuts for various browsers –  Srijan Jun 28 '12 at 15:30
    
1) I'm not trying to solve the input problem now - one thing at a time. 2) I'm able to open Firefox and any other application through the launcher using the super key, so that is not the problem. The problem is the internet connection. –  Ben Jun 28 '12 at 17:29

What does clicking the top portion of your screen have to do with connecting to the Internet? That happens automatically when Ubuntu "senses" the network connection.

By "connecting to the Internet," do you mean launching your web browser? And you can't do that because your task bar and system/start menu are at the top of your screen? If so, you could press Alt-F1 to open the menu.

share|improve this answer
    
I think the problem he has is that ubuntu does not automatically connect to a network. So he needs to access the networking menu in order to select a network to connect to –  Daniel Jun 28 '12 at 15:46
    
A little sensitive, are we? Downvoting an answer because the question is unclear? Wow. Humanity never ceases to amaze me. –  Tom Jun 28 '12 at 15:49
    
I didn't mean to be a dick by down-voting. But your answer is pretty much the same as the first one. And if the question's unclear ask for clarification in the comments. –  Daniel Jun 28 '12 at 16:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.