Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I put the last Ubuntu iso on my USB stick using UNetBootin, after formatting it to fat32. I've already done that before with other operating systems and it worked. I can't actually boot Ubuntu from USB since I get a black screen with the error "Machine check error" on top the an automatic reboot happens. The error appears right after the boot, I can't see anything else before.

I'm using my ASUS K53SV latop. Does anybody know how to solve this?

share|improve this question
    
Check and see if there is a BIOS update for your system. – Mitch Jun 28 '12 at 17:30
    
I already did, I have the latest BIOS, thanks! And I do remember in the past I was able to run a Live Ubuntu from USB, maybe it was with the previous version. – javanna Jun 29 '12 at 7:32
    
How old is the laptop? Because the error says that there might be a fault in the CPU. – Mitch Jun 29 '12 at 7:40
    
The laptop is 8 months old and is working fine. – javanna Jun 29 '12 at 7:59
1  
I have the same laptop and the same problem with LMDE 64-bit. So I guess it's very probable that it's faulty. Have you tried just redoing the USB stick with Unetbootin, or else trying with a different stick? Because I have correctly installed Ubuntu before. – user81296 Aug 4 '12 at 16:19
up vote 1 down vote accepted

More a workaround than a solution, but since I couldn't solve the problem with the USB stick, I was finally able to boot from a CD, that's how I installed Ubuntu on my Laptop.

share|improve this answer

Apparently is completely related to the Bios settings. Try:

First of all, double check that the .iso image you downloaded is sane. In order to do that you can check the MD5SUM signature to completely discard that your iso is corrupted due to an incomplete download. (I know it is a silly thing, but it was actually my first error, the image was corrupted. If that's your case too, download it again).

1) Disable the "secure boot" feature in your bios

-Reboot, select the boot unit (that should say something starting with UEFI if you are booting from a USB Stick) and try to boot. If that does not work, try the next step.

2) if you have an intel processor, then try disabling the "Vitualization Technology" feature

*-Reboot, select the boot unit (that should say something starting with UEFI) and try to boot. That worked for me. *

notes: for sure you will need to disable the first. Try it alone, then try it combined with the Virtualization Technology disabled. If it works, like in my case, you can turn it on again cause it affects the performance of the virtual machines you may use (e.g. with VMWARE or Virtualbox). If you don't know what a virtual machine is, then you can leave the VT off.

Tested in an Asus Zenbook from 2014.

Cheers!

share|improve this answer

protected by Community Oct 24 '12 at 10:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.