Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am quite confident under hardy I only had to change the color depth to 16, although I can't remember which driver (ati, r128, fglrx) I used. I tried ati and r128 (fglrx seems to crash) but I still cannot increase the screen resolution to 1024x768, which worked under hardy. What else do I need to do? Is there something I have to add to the Monitor section of xorg.conf perhaps? The notebook is a Dell Latitude C600.

share|improve this question
add comment

2 Answers

You may have been using fglrx on Hardy, however AMD/ATI dropped support for older graphics cards such as yours. So you will need to use the -ati driver instead.

The suggestion in the previous comment to purge fglrx when you have used both fglrx and ati is good advice in general. If you're trying to use -ati and there's still some fglrx kernel driver or glx library laying around, it can cause confusion. Generally that doesn't affect resolution but the problems are rather unpredictable.

Assuming you're using the open source -ati driver now, one option you can try is to turn off kernel mode-setting. This is because whereas X used to be responsible for selecting resolution, these days the kernel does it. (This is called Kernel Mode-Setting, or KMS). If it used to work (in the old days with UMS) but now isn't (with KMS), here's a guide to switch back to UMS for -ati: https://wiki.ubuntu.com/X/KernelModeSetting

Another common thing to check on these old graphics cards is the AGPMode setting. Possible values are 1, 2, 4, 8. It seems a bit unpredictable what number is required; 2 might work for one machine, and on a seemingly identical one you have to use a different value. The -ati developers haven't figured out a good way to guess this reliably in all cases.

Beyond that, check your Xorg.0.log; midway through it goes through the resolutions and decides which ones fit the refresh rates of the monitor. Sometimes if there are problems it'll become evident there. For instance, if its trying to find a common resolution that works for both the LVDS and for VGA (even though no VGA is present), or if there is an error in the EDID or something.

Finally, in theory -ati should run fine with no xorg.conf present. If you haven't tried it already, just move aside your /etc/X11/xorg.conf and see what happens when you run naked. Half the time this will solve the problem.

share|improve this answer
    
I started with no xorg.conf and had to create one in order to lower the color depth. But thanks for the KMS link, I'll give that a shot, too –  Tobias Kienzler Aug 9 '10 at 12:15
add comment
up vote 0 down vote accepted

For my DELL Latitude C600 I just had to follow this post (note that the dpkg-reconfigure line needs sudo prepended as usual):

I'm Not sure about distribution differences, but this worked for me on Xubuntu 8.10 with the same hardware. Unfortunately it's not capable of playing the latest and greatest of games from what I could read: however I was happy to finally get it to work at all I scanned posts and howto's all over the web for weeks. I'm still fairly new to all of this and have no intentions of reverting to windows especially now. I just found this thread http://ubuntuforums.org/archive/index.php/t-370219.html. The very last post is what tipped me over the edge the steps that i took before that was to manually configure xorg.conf which supposedly does not get read in Xubuntu 8.10. Anyway here are some commands to run through first.

This is exactly what I did

sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
dpkg-reconfigure -phigh xserver-xorg

Then back up your xorg.conf located at /etc/X11/xorg.conf

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Then I edited the xorg.conf file located at /etc/X11/xorg.conf to look like this

sudo gedit /etc/X11/xorg.conf

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Module"
Load "i2c"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "Device"
Identifier "ATI Technologies Inc. Rage Mobility M3 AGP 2x"
Driver "ati"
BusID "PCI:1:0:0"
VideoRam 8192
Option "AgpMode" "2"
Option "EnablePageFlip" "true"
Option "Accel" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-70
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc. Rage Mobility M3 AGP 2x"
Monitor "Generic Monitor"
DefaultDepth 16
EndSection

Section "DRI"
Mode 0066
EndSection

#
#
#Section "Device"
# Identifier "Configured Video Device"
#EndSection
#
#Section "Monitor"
# Identifier "Configured Monitor"
#EndSection
#
#Section "Screen"
# Identifier "Default Screen"
# Monitor "Configured Monitor"
# Device "Configured Video Device"
#EndSection
#
#

Save the file and reboot

sudo reboot

If you just copied and pasted that xorg.conf file above you should have booted up in 1024x768 resolution and if you run glxinfo in terminal direct rendering should say yes

my glx gears were at 420 in 5 seconds when i started this project two weeks ago and about 1 hours ago i finished with the instructions described (i just found them a little before that it didn't take me two weeks to follow them)

glxgears

3571 in 5 seconds

I tested on a myspace app Dragon wars it ran very slow and that is no where near the games out there today but it worked. Hope someone finds this useful

dmatthys

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.