Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using a static wired connection. Everything was perfect.

But suddenly from few hours back I can't access any website. Dropbox, Ubuntu One also can't connect.

Ping request is also unsuccessful, but I can download through torrent. I am not trying torrent download and browsing at the same time. So, I think it's not an issue about torrent using all the bandwidth.

One important point is that this connection works perfectly on Windows on this same PC (My PC is dual-boot).

I have tried the way what izx has suggested (using "sudo sh -c 'echo nameserver > /etc/resolv.conf'"), but I'm facing the same problem again. Now I can't even ping and Though I can ping (which is Google IP address)

I can't understand what's happening and why this is happening. I'm new in this website many rules and regulations is unknown to me. So, please don't be bothered for my mistakes. Looking forward for help from anyone.

Thanks to all.

share|improve this question
DNS may have gone crazy. Does ping work from Ubuntu? If so, try sudo sh -c 'echo nameserver > /etc/resolv.conf' , and then see if things work better. – izx Jun 28 '12 at 6:23
This generally happens when you download torrents, I think your router cannot handle the multiple connections. Example: You have 1000 connections/requests through the torrent program and 1 request for a website. Which one do you think will go through first? :) Have you tried tweaking the torrent program settings? For example lower the active downloads, lower the connection speed? Which program do you use for torrents? Have you tried alternative programs? – medigeek Jun 28 '12 at 6:25
Thanks izx. Thank you so much. Your solution works perfectly. I'm really grateful to you. Your profile shows that you are a very experienced Linux user. I'll be so much happy to add you on my contact list. So, could you please give me your Skype ID. So that I can add you? Looking for your reply. Lastly, again thanks. – Fahim al Islam Jun 28 '12 at 9:19
@medigeek Thanks for your try to help me. – Fahim al Islam Jun 28 '12 at 9:31
I'm facing same problem again. @izx your solution was great also it works perfectly for few hours. May be your guessing is correct some problem with DNS. But now ping is also not working. Could you please tell me what can I do now? I think you have the solution. Please also could you tell me why my DNS is acting like this? what's the reason? Please respond soon. – Fahim al Islam Jun 28 '12 at 18:47

You don't say what version of Ubuntu you are running. I will assume 12.04 for now.

On 12.04 and later, you shouldn't be editing /etc/resolv.conf as any changes there get overwritten by other tools.

Generally, network configuration is now managed in NetworkManager. Firstly then, check NetworkManager: using the network indicator in the top bar, open the settings for your connection, check the IPv4 tab a report back what is there.

If it is anything other than auto, make a note of all of the settings, then change it to "Automatic (DHCP)". See if that helps.

The next thing to check is the output from:

cat /run/nm-dns-dnsmasq.conf

Since this is where NetworkManager squirrels away the DNS settings. On my machine, which uses OpenDNS as set in my routers DHCP settings, I have:


(This doesn't work in Ubuntu 12.10 because in Ubuntu 12.10 NetworkManager sends nameserver addresses to the local forwarding nameserver over D-Bus.)

From the command line:


will tell you all of NetworkManager's settings.

You should also note that the output of cat /etc/resolv.conf should look like:

search home.gateway

/etc/resolv.conf itself should be a symbolic link to ../run/resolvconf/resolv.conf.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.