Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The gamepad is more or less a clone of a xbox controller (IIRC it is even from the same manufacturer), labeled PCPADRFLX. lsusb lists the receiver as ID 1a34:0801.

dmesg | grep input reads

[6880.468415] input: ACRUX RF USB GAMEPAD 8206 as /devices/pci0000:00/0000:00:10.1/usb2/2-2/2-2.3/2-2.3:1.0/input/input17

Unfortunately, while the receiver is recognized, the gamepad itself does not connect. Usually after pressing a button on it the LED would light up once to indicate it has connected, however it just blinks as it does when no receiver is connected at all.

So, how can I make the gamepad work?

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:34

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I read that it works under gentoo, so maybe someone who knows that better than me can figure out the difference –  Tobias Kienzler Aug 7 '10 at 12:07

3 Answers 3

tips is a good treat to search google with the id of lsusb with this type of problem exam... 1a34:0801

http://ubuntuforums.org/showthread.php?t=825464

share|improve this answer
    
I did google that id, but even searching on ubuntuforums I did not find this specific thread - which looks helpful indeed, I never found instructions how to actually make the driver sync, so thank you already. Since I can't check these instructions at home before the bounty expires, I'll award it on good faith and accept later if it works. –  Tobias Kienzler Oct 18 '10 at 8:14

Have you seen this page?

https://help.ubuntu.com/community/Xbox360Controller

They talk about drivers which may help you.

EDIT: There is also a userspace driver: http://pingus.seul.org/~grumbel/xboxdrv/ if you don't want to use the kernel module for some reason.

share|improve this answer
    
I tried that (see here), but seems different enough from a real xBox controller to not work :( I modified grumbels driver to recognize it, but still there was no way of connecting. The win driver seems to cause a permanent sync-fire by software, which the xbox driver apparently doesn't –  Tobias Kienzler Oct 14 '10 at 7:23

I once got the black BigBen Wireless gamepad working, but I forgot how to. I remember that I installed a lot of stuff (also the x360 driver for Linux) and suddenly it worked. I can't remember which version of ubuntu it was. It must have been 9.04 or 9.10.

I remember I played Super Mayo Chronicles with it and it worked fine. So there is a way. If someone finds out how, a documentation would be great. Next time I try I will write down every single step I make.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.