Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I configured IPTUX to run in background by mistake. The next time when i start it always runs in back ground. i tried to reinstall and also reinstalled with synaptic. still it starts in background.

Thanks, Kavin

share|improve this question

I am stuck in the same situation but I know one thing for sure that you can modify the %gconf.xml file directly using

sudo nano <config file path>/%gconf.xml

which should be located in any of the following locations




I did modify the file but when I restart the system it seems to have reverted back to the original.

The entry in the file that you need to look for, to modify is:

name="hide_startup" mtime="1343670281" type="bool" value="true"

change it to:

name="hide_startup" mtime="1343670281" type="bool" value="false"

I believe, the reason for the file reverting back to the previous state is that iptux process must be running in the background and hence not allowing changes to the file.

What I am looking for is a way to kill the iptux process before modifying the config file, but can't find a process for iptux.

Will research it a bit and let you know if I find the process name.

share|improve this answer
What I found out was, that you cannot stop iptux as it doesn't have a process of its own but relies on other processes (won't get in depth here) but My solution would be to start Ubuntu in repair mode, by pressing F8 a bit after the bios screen disappears (before the Ubuntu Loading Screen) and select repair... or was it recovery mode... but you get the idea. You can then use the terminal to modify the file. In this way iptux won't have started and the file should be modified fine. – exIT Solutions Jul 31 '12 at 13:19
Let me know how it goes. I can't try this as my issue is a step up... I am having the issue on the Thin Client rather than the server. I'll probably try to shutdown the thin client then modify the config file. – exIT Solutions Jul 31 '12 at 13:20
Yep, that worked for me. Guess you'll have to logout of your profile and log in as administrator or root (not recommended) then modify the file or start terminal in so called safe mode or recovery mode – exIT Solutions Jul 31 '12 at 13:29
What I found out was it doesn't matter if iptux is running in the background but so as long as the profile (login) that is creating the problem is not in use or locked. What this means is that if you simply log out and log in as another user or admin you should be able to modify the problem profile's iptux config file (xml) – exIT Solutions Jul 31 '12 at 13:32
I suggest to use sudo nano /home/<your username>/<iptux config file path>/%gconf.xml and modify to false as discussed earlier. – exIT Solutions Aug 1 '12 at 1:19

I also had the same problem. The solution was as specified by exIT Solutions is :

  • First locate the %gconf.xml file in your pc. Mine was in ~/.gconf/apps/iptux/%gconf.xml. Edit it with any Text Editor.

  • Second search for the line:

entry name="hide_startup" mtime="1410256594" type="bool" value="true"

and changed it to:

entry name="hide_startup" mtime="1410256594" type="bool" value="false"

Save the file and logout. After logging in I started iptux and it worked fine.

share|improve this answer

I also had the same problem. So i uninstalled iptux and removed all the files related to iptux in the system. Then i reinstalled iptux and it worked.

share|improve this answer
Welcome to Ask Ubuntu rohitrounak! Even though your answer attempts to answer the question, it would be better to add the actual steps on how you did this, as in the actual commands. This is so that (1) you can help other people that don't know the commands, and (2) the person that asked the question seems to have already tried reinstalling IPTUX, but maybe you did more actions than what he did. You can edit your answer and include the steps. – Alaa Ali Jul 8 '13 at 7:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.