Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Banshee from the Ubuntu Software Center after installing VLC and Clementine, but I'm running into errors:

I tried installing from terminal but got this:

Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 banshee : Depends: libglib2.0-0 (>= 2.32.3) but 2.32.1-0ubuntu2 is to be installed
           Recommends: banshee-extension-soundmenu (= 2.4.1-3ubuntu1~precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
share|improve this question
    
Have you added any PPAs to your software sources? Is this a clean installation of Ubuntu 12.04, or did you upgrade from a previous version? –  michaelms Jun 28 '12 at 11:51
    
It is clean installation of ubuntu 12.04 –  Rohan Jun 28 '12 at 13:17

1 Answer 1

up vote 1 down vote accepted

Have you tried sudo apt-get -f install banshee? The -f argument should install all dependencies required, along with the actual program (that's important). It's weird that the dependencies in a .deb didn't install.

If that does not work, you should probably check and see what repositories you have (open up software center, go to edit, then go to software sources). You should have a few in there, and make sure the correct fields are checked.

It is important that Canonical is selected.

share|improve this answer
    
The dependencies won't install. Take a look at the errors, its looking for newer software versions than are available on the system. For most of the deps, at least. For the others, the ones throwing the errors where it needs newer versions but there is a valid version are probably depending on those which need a newer version which does not exist on the system. –  Thomas W. Jun 28 '12 at 12:49
    
Ahh kk, I couldn't see the text in the snapshot well, so I assumed it just wasn't installing the dependencies along with the main package which was causing the main error. I wonder if they are available to the system, but the repository is messed up. –  Compt Jun 28 '12 at 13:12
    
You can try my method, but from what Lord of Time has said, it may not work as the system is looking for newer software versions. I was able to install banshee, but this was a fresh install, and all the repos are in. You should probably check and see what repositories you have (open up software center, go to edit, then go to software sources). You should have a few in there, and make sure the correct fields are checked. –  Compt Jun 28 '12 at 13:25
2  
Hey compt your solution worked. "Canonical Partners" wasn't checked in software sources. –  Rohan Jun 28 '12 at 13:39
    
That's good :D. In 11.10, I had a problem where nothing was ever updating. Turns out it somehow became unchecked. Suffice to say, it's small things like a check box that can make a huge difference lol. –  Compt Jun 28 '12 at 13:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.