Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed wine from the Software Center and kept getting errors when trying to load Windows programs.

Uninstalled and did the apt-get installation of the latest version (1. 5. 7)

Ran Wine configuration and get a "Failed to connect to the mount manager, the drive configuration cannot be edited"

If I try to install a program it immediately goes to "Internal error".

Ran winecfg and got the following:

Getting server_pid from lock 2457
wine: cannot get pid from lock (lock isn't locked)

Err: processtart_wineboot failed to start wineboot, err 1359

P11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file:
No such file or directory

Getting server_pid from lock 2457

Wine: cannot get pid from lock (lock isn't locked)

Err: winecfg: WinMain failed to restart 64-bit L"C:\\Windows\\system32\\winecfg.exe", err 1359

Getting server_pid from lock 2457

Wine: cannot get pid from lock (lock isn't locked)
share|improve this question

closed as off-topic by Luis Alvarado Jul 26 at 3:47

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Ran winecfg and got the following: –  Dale Jun 28 '12 at 2:54
    
getting server_pid from lock 2457 wine: cannot get pid from lock (lock isn't locked) –  Dale Jun 28 '12 at 3:01
    
err:process:start_wineboot failed to start wineboot, err 1359 –  Dale Jun 28 '12 at 3:01
    
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: –  Dale Jun 28 '12 at 3:02
    
/usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory –  Dale Jun 28 '12 at 3:02

5 Answers 5

I was running Wine 1.5.7 perfectly well on 12.04 but after an upgrade this morning I started getting the errors you describe. It was the 1.5.7-0ubuntu3-pulse18 versions that were the problem.

(EDIT: Thanks to swift work on the part of the Wine packaging team, you can now upgrade away from the troublesome version. Try that first before attempting the downgrade method below.)

Fortunately I still had the 0ubuntu2 versions in my cache so I could downgrade like so (I'm on 64-bit, so if you're on 32-bit the dpkg line will be different).

cd /var/cache/apt/archives/
sudo dpkg -i wine1.5_1.5.7-0ubuntu2~pulse18_amd64.deb wine1.5-amd64_1.5.7-0ubuntu2~pulse18_amd64.deb wine1.5-i386_1.5.7-0ubuntu2~pulse18_i386.deb
sudo apt-get -f install

Having done so Wine is working again. If you don't have these packages you can get them here:

In which case, run the dpkg command from where you downloaded them, rather than your apt cache.

share|improve this answer
    
That doesn't seem to work here. :( –  Jo-Erlend Schinstad Jun 28 '12 at 13:35
    
Didn't work. Ended up with broken packages and dependencies. Software center is also broken. May have and start over with a fresh install of 12.04. –  Dale Jun 28 '12 at 17:55
    
I see a new version 0ubuntu4 is now available in the repos, which may also solve the problem, though if the troublesome 0ubuntu3 version has broken your Wine prefix you may have to recreate it from scratch. You should be able to upgrade to the new version in the usual way, e.g. on the command line sudo apt-get update && sudo apt-get upgrade. If you have broken dependencies, you'll need to use Synaptic rather than the Software Center to fix them; there's help on the Community Help Wiki. –  Alex Ball Jun 29 '12 at 8:56
    
Thanks a lot Alex, I had first downgraded to version 1.5.5 (simply by restoring my partition backup image created by Clonezilla) and then saw this and successfully upgraded to version 1.5.7-0ubuntu4-pulse18 which solved the problems. –  Sadi Jun 29 '12 at 11:41
    
I also ended up with a broken system because of these dependencies. I'm not able to either install or remove anything. Any idea how to fix this? –  Jo-Erlend Schinstad Jun 30 '12 at 13:22

I have had much success with crossover (http://www.codeweavers.com/) and my coworkers have found success with oracle's virtual machine virtual box ( http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html ) As far as completely open source wares go, I haven't gotten Ubuntu to install office 2007 using the standard wine distro.

share|improve this answer
    
Thanks. Alternate solutions are a last resort. With version 11.04, wine ran fine. Upgrading to 12.04 has been more problem filled than any other version I've tried and is making me regret migrating from windows. –  Dale Jun 28 '12 at 3:32
    
I have found Crossover Linux to be great. I purchased it just to support them, but then I needed their support and I found it to be tremendous. They helped me get a Win app running that would absolutely not work in wine. –  MountainX Jan 25 '13 at 21:31

Have you tried to install the WINE Launchpad PPA yet? This is different from the Software Center. Updates to WINE are delivered via their PPA.

After doing that, try installing again.

And be sure to NOT be installing or removing any other packages during the install. Applications have to get a "lock" to prevent other packages from installing/uninstalling when it is trying to install/uninstall.

share|improve this answer
    
Can you edit your answer to include specific instructions for enabling this PPA, or a link to such instructions, or both? –  Eliah Kagan Jun 28 '12 at 20:41

I've run into the same problem. Looking at your error output it looks like Wine can't find the gnome-keyring-pkcs11.so file which should be located in /usr/lib/i386-linux-gnu/pkcs11.

In the terminal try typing

sudo find / -name gnome-keyring-pkcs11.so

The sudo will allow you to look inside folders that you may not normally have access to. If it can't find gnome-keyring-pkcs11.so then the problem is just that the file doesn't exist and as a Linux noob I'm not sure where to go from there. If it DOES exist but isn't in that folder then you will need to either copy the file to that location or create a link to it and put the link in /usr/lib/i386-linux-gnu/pkcs11.

I haven't tried this out yet but I will as soon as I get a chance.

share|improve this answer
    
Created a link in the correct folder and now get a different error. "p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: wrong ELF class: ELFCLASS64" Must be looking for an i386 module instead of 64 bit. –  Dale Jun 29 '12 at 4:45

This is due to multiarch, unless it will break some stuff , just try this once multiarch set :

apt-file search gnome-keyring-pkcs11.so
#| gnome-keyring: /usr/lib/x86_64-linux-gnu/pkcs11/gnome-keyring-pkcs11.so
sudo aptitude install  gnome-keyring:i386

--

http://rzr.online.fr/q/64

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.