Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Vostro 3700 version A10.

The relevant bits from lspci -v | grep VGA are:

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 330M] (rev a2)

So as you can see this is one of those hybrid graphics laptops. Now, I have no interest in any kind of switching. I would like to completely disable the Intel Graphics thats on the processor.

I checked in the xorg.log file and it shows that the intel card is in use.

From lsmod I see it uses the i915 module. I tried blacklisting that module in /etc/modprobe.d/blacklist.conf but that didn't really work because i still couldn't use the nvidia card for display.

I wish there was a BIOS option to disable, but there isn't. Some people have also suggested changing the SATA mode to compatibility, but that does not work either in this case as the intel vga controller still shows up in lspci

I tried setting the busid manually in the /etc/X11/xorg.conf file but it still didn't work. It gave me an error that said something along the lines of screen not detected. any bits of xorg.log that you'd like me to attach?

So what I am looking for is some solution that allows me to completely disable the use of the intel vga controller. if it was blocked somehow it'd be nice. as if it were not present. Any suggestions? I am desperate here actually. Because I cannot use the HDMI port right now on my laptop for that reason.

My guess is this applies to desktops that also have Core i5 processors with onchip graphics as well as dedicated graphics cards. How would they go about solving the problem?

share|improve this question
    
As far as I can make out, this is not an Optimus system but it has similar issues. I'm asking in a nvnews.net thread to see if there's any news on a workaround for this setup. –  Oli Dec 1 '10 at 14:16
    
thanks @Oli! I am quite sure in my case that the HDMI port is linked to the nvidia chip. Wonder if there was a way to turn both cards on then! –  Eshwar Dec 2 '10 at 12:42
    
Seem to have found a solution. Recently had a motherboard replacement and that strangely required graphics drivers to be reinstalled in windows. I have not done that and when i booted to ubuntu, I can no longer find 2 VGA adapters listed in lspci output. It only detects the nvidia one. So I just installed nvidia-current and it works great! BUT ofcourse it means bad graphics in windows. I am not sure if the graphics driver installation triggers some sort of hardware switch in windows that sets the intel one as the primary. so right now its my only option! –  Eshwar Jan 12 '11 at 9:38
add comment

3 Answers

Try to install bumblebee to have both the Intel and Nvidia cards working simultaneously: https://launchpad.net/~hybrid-graphics-linux

sudo apt-get install git
# type password
git clone http://github.com/MrMEEE/bumblebee.git
cd bumblebee/
sudo ./install.sh
optirun glxgears
# check the speed and compare to running:
glxgears
# If you have google-chrome installed, you can try it with/without optirun and report the FPS values on the mailing list:
optirun google-chrome http://webglsamples.googlecode.com/hg/aquarium/aquarium.html
share|improve this answer
1  
Does bumblebee allow vdpau now? or not yet? when vdpau is in, i'll jump onto the ship! –  Eshwar Jul 26 '11 at 16:13
    
bumblebee doesn't do vdpau, and it seems like hybrid-windump is the best option for that so far: github.com/MrMEEE/bumblebee/issues/16 –  213441265152351 Jul 30 '11 at 5:18
1  
I have installed bumblebee and it works, but how can I disable the Intel Graphics by default. I would like to run my system always on Nvidia. Thanks. –  Kostanos Sep 1 '13 at 2:15
    
@213441265152351, would that work on a hybrid desktop? I have an integrated Intel + a PCIe nVidia on my desktop, but am insecure about installing Bumblebee, since the documentation seems to be clear about it being a solution for laptops. –  Waldir Leoncio Sep 15 '13 at 17:49
add comment

You can try vga_switcheroo.

cd /sys/kernel/debug/vgaswitcheroo
cat switch #to see which card is active. Pwr - powered on, Off-powered off, "+" - active card.
echo OFF>switch #to power off inactive card
echo ON>switch #to power on inactive card
echo DIS>switch #to switch to discrete card immediatly(not work with X started)
echo DDIS>switch #to switch to discrete card after X restart
echo IGD>switch #to switch to integrated card immediatly(not work with X started)
echo DIGD>switch #to switch to integrated card after X restart

Works only with open-source i915 and nouveau drivers. I have the same notebook, and it is only power ON and OFF works for me.

P.S. As I remember(not sure) A08 BIOS has "Hybrid Graphic" option. But i cant rollback to older BIOS version to check it.

share|improve this answer
    
i've go the 2.6.37-12 kernel installed on lucid but sadly vga_switcheroo doesn't appear for me. then again, i'll detail what has happened in a separate comment. –  Eshwar Jan 12 '11 at 9:36
add comment

Aha. Following on from my comment, I found my way onto Dell's BIOS support page.

It suggests that in the BIOS (under Advanced -> System Configuration) there is an option called "Hybrid Graphic" where you can turn off the Hybrid function.

I'm not which video device this dumps the video on, but it looks like a good start.

share|improve this answer
    
yeah i came across that. what's on the page and what's on the laptop are two different things unfortunately!!. and thanks for asking on nvnews.net. A simple way to disable the intel card or switch to nvidia early on in boot would be a great help! –  Eshwar Dec 1 '10 at 14:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.