Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 10.04 on my hp mini 110. All worked out of the box except the wireless (as expected), so I followed the plethora of forum posts and installed/activated the STA driver. This worked and I am connected to the Internet but the wireless notification shows the red exclamation point over the wireless notification anyway...does anyone know how to fix this to show the correct notification?

Also, after installing the broadcom-sta-common package I did not uninstall any packages (I read several places about blacklisting or uninstalling the b43/ssb drivers). So are there any unnecessary packages I should remove from synaptic due to installing the STA packages?

Thank you for any advice in advance.

share|improve this question

1 Answer 1

Maybe the system kernel doesn't work with your wifi firmware. Try it to make a hosyap, and compile the two into the kernel.

It's a hell of a job.

First install the newest driver and firmware in Windows.

You can check the compatibility from the wifi chipset and the kernel version in your Ubuntu release.

If they are compatible, download the driver for Linux-based systems.

Also you can start airdriver-ng in the a graphical terminal window, and follow the manual.

Good luck if you going to need airdriver.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.