Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

by a series of errors, Python 2.7 was installed over 2.6 within Ubuntu 10.04. Both appear to be working, however many things are not (yolk, freenx, easy_install, pip, etc).

I believe the issue is that 2.7 is now seen as the default for python, but the OS is still trying to use 2.6. For example, when I try and run yolk, I get:

user@linuxbox:/usr/local/lib$ yolk -l
Traceback (most recent call last):
  File "/usr/local/bin/yolk", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/local/lib/python2.6/dist-packages/pkg_resources.py", line 2735, in <module>
    working_set.require(__requires__)
  File "/usr/local/lib/python2.6/dist-packages/pkg_resources.py", line 690, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/local/lib/python2.6/dist-packages/pkg_resources.py", line 588, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: yolk==0.4.3

Is there a way to rip 2.7 out, and revert everything back to 2.6?

share|improve this question

1 Answer 1

After a long search I found something that appears to have worked:

sudo ln -f /usr/bin/python2.6 /usr/local/bin/python
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.