Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot connect to Internet using BSNL EVDO Prithvi data card. Went through some websites that offered help, installed wvdial package and tried again, but was unsuccessful.

I have Read that, Ubuntu 11.04 automatically detects Data Card, You only need to configure "Network Manager" and it will work, I did exactly that, but the result is same.

The OS detects the data card, and the presence of network , but it cannot login.

I have read in some forums that Ubuntu 11.04 does not have support for BSNL EVDO Prithvi, is it true?

I re-checked the "User ID" and "Password". Its working on Windows.

Please help me fix this.

share|improve this question
    
Can somebody help me out please? –  Joy Jun 28 '12 at 18:10

1 Answer 1

up vote 1 down vote accepted

Joy, I could make it work with wvdial just now! Even I have the same BSNL EVDO with the Prithvi dongle, and it does not connect using the Network Manager (but others like docomo do). Try the following:

Configure wvdial with correct number (#777), your username, password and Stupid Mode = 1. This I presume you would have already tried. Now, if on running wvdial, you are able to see till secondary DNS getting allocayed, try this one last step. This is what saved me:

You might have issues with resolvconf stomping on your DNS configuration in /etc/resolv.conf - but if you're getting an IP address from the remote peer then the modem is working, even if you can't access any websites etc. If you don't use resolvconf, consider just uninstalling it.

Source: https://wiki.ubuntu.com/NetworkManager/Hardware/3G/Probing

share|improve this answer
    
i tried using wvdial dude, but will try again with the mentioned setting! btw how do i know if i use resolvconf ? i guess the Q is dumb but i just dunno :( –  Joy Jul 27 '12 at 5:14
    
It works dude! resolvconf was the culprit, but does it have other effects on the system? –  Joy Jul 27 '12 at 13:59
    
However one issue is there, the Software Centre does not detect the connection hence won't install!!! Any fix for this? –  Joy Jul 27 '12 at 14:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.