Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

New to Ubuntu and really struggling with this. I want to connect to my old windows XP PC on our home network. Searching for solutions gets complicated as at one level you are told use

Connect to Server. I set to Windows Share, type in server IP address..

... I get "Failed to retrieve share list from server"

Demo on Youtube worked with no problem.

Other advice in ask Ubuntu is you need to install samba. Did that but nothing seems to happen when I try and run it other than it asking for admin password. (How do you tell what is running on Ubuntu?)

So I try the other direction Windows XP to Ubuntu. I made the Ubuntu directory within home frank shared and tried various combination such as \ipaddress\home\frank but just "The folder you entered does not appear to be valid. Please choose another." My entire data only drive is shared in Windows and no problems accessing that from other Win XP boxes on our network

There are no alerts in Windows firewall, Ubuntu Firestarter did block but changed that to allowed... or so I thought.

In firestarter I had set up Inbound traffic policy 192.168.1.1/24. And since then it has added the ip address of the win pc twice.

So, I am in a state of confusion not knowing where to turn next so thought Ask Ubuntu :)

share|improve this question
    
you can always check if your samba por is listening: type in the terminal netstat -nat | grep 445 –  maniat1k Jun 27 '12 at 15:16
    
Well all went well the other day, but now it is refusing to accept my password... how can I set things up so I do not need a password at all. –  Frank A Jul 3 '12 at 21:54

1 Answer 1

up vote 1 down vote accepted

First of all, turn off Firestarter while you troubleshoot this. It will only complicate any problems, and you won't know if they are caused by a samba misconfiguration or Firestarter. Once you get the connection working, you can re-enable Firestarter.

Check out these Samba Troubleshooting links:

Samba uses smb.conf for its configuration. Here is a portion of my smb.conf where I create a share called "shared" that I access from both Win XP and Win 7.

[shared]
    comment = My Shared Partition
    path = /mnt/shared/
    browseable = yes
    available = yes
    read only = no
    guest ok = no
    valid users = my_windows_account_name
share|improve this answer
    
Thanks for quick response. So would my path be /home/frank ? –  Frank A Jun 27 '12 at 15:15
    
I tried editing that file but it does not allow me to. Tried changing permissions, it does not allow that says I am not the owner. Help not helpful as not a word about if you are not the owner of your own files!!! Huh? Why is Samba needed and not just the Connect to Server? –  Frank A Jun 27 '12 at 15:34
    
Changed owner to my user by using Press ALT+F2 and type gksu nautilus. Now I can edit it but when I come to save I get an alert saying it could not make a backup copy, with option to save anyway... did not work.. so changed ownership of Samba folder to me and finally got is saved –  Frank A Jun 27 '12 at 15:42
    
I ran Samba again. Entered password. Should something display after that? –  Frank A Jun 27 '12 at 15:52
    
The path (/mnt/shared in my example) is the folder to be shared. When you connect to \\computername\shared from another computer, you are actually connecting to /mnt/shared. What command did you use to "run samba again?" –  Tom Jun 27 '12 at 15:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.