Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am working with ubuntu 12.04 server 64-bit edition. I have intalled apache2 without any problems and i can see the "It works" message. And i can also access from other pc within the network.

I want to host my website using home DSL, However i found out that my ISP is blocking the port 80, 25 ,110 so i changed the port to 8010 (/etc/apache2/port.conf)

After this I am unable to get the "It Works" web page. All it shows that "NOT FOUND" i tried with ipaddress:8010 and it doesnot work with both internal and also external.

share|improve this question
    
whats the output of sudo netstat -ntlp –  Shutupsquare Jun 27 '12 at 14:24

2 Answers 2

Make sure you changed the port correctly.It is quite easy .You need to make few changes to httpd.conf file as follows: Listen 80 to Listen 8080 and ServerName localhost:80 to ServerName localhost:8080

For more detailed info with screenshots ,you can refer this - http://www.superpctricks.com/2013/11/running-iis-and-apache-on-same-server.html

share|improve this answer

You have to change your VirtualHost setting, too

Edit /etc/apache2/sites-enabled/000-default

Change

 <VirtualHost *:80>

to

 <VirtualHost *:8010>

And make sure that your ports.conf looks like

 NameVirtualHost *:8010
 Listen 8010

And don't forget to restart the apache

share|improve this answer
    
when i type the address for ex: www.xyz.com the browser changes it to my ip address... does that because i have not set up DNS yet? Also i heard when you change the apache port no DNS (BIND9) doesnot work. Is that true? –  user73595 Jun 27 '12 at 14:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.