Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Good day! I have installed ubuntu 12.04 on my laptop and I need to have network connection on it. Have a desktop PC, where I've created ad-hoc wi-fi network(Windows 7) and can't connect to it.

So, problem: I see my network in the list of networks to connect, but I cant connect to it because it's grey color and not active(can't click on it).

Could somebody help me to solve that problem? Thanks in advance!

share|improve this question
add comment

2 Answers

I know that under 10.04 you had to go and manually change the mode of the network in the Ubuntu network settings to Ad-hoc, I've not used WiFi on 12.04 but is this the same issue?

UPDATE: OK, I've not got wireless installed on my Ubuntu box just now. However, if you click on the up/down arrow in the info bar at the top of the screen.. Then "Edit Connections" - Wireless. You should have a wireless connection entry in the list. If not, you will need to add one. In the settings box for the wireless connection, the second box down is labelled "Mode". This should be on "Ad-hoc" not on "Infrastructure".

If it is already set to Ad-hoc, make sure that the SSID is correct. If the Band is set to auto, try the correct band for your desktop PC, also check that the Channel is set to the same as your desktop. On the security tab, change the security to match your desktop; Win7 defaults to WPA2-Personal. Make sure that you've entered the key correctly. On the IPv4 tab, try manually setting the IP details. Choose an unused IP address on the same network as your desktop. For example, if the desktop has an IP of 10.0.0.1 associated with the Wireless network, the "mask" will be 255.255.255.0 by default so you must choose an address of 10.0.0.2 - 10.0.0.254, make the gateway the IP address of the desktop (e.g. 10.0.0.1 in this example).

share|improve this answer
    
Don't know, but maybe you can tell, what exectly I need to do? –  Nikolaj Jun 27 '12 at 18:37
    
Thanks, but this doesn't help me... I've remove password and made my network(adhoc, as you remember) open - now I can connect to it, it's active in the networks list. Maybe this would help you to create some new ideas, what could help me... Thanks in advance! –  Nikolaj Jun 28 '12 at 19:28
    
If you have removed the key phrase and you can now connect successfully, that indicates that the issue is with the key. There used to be problems entering keys as there were two methods, basically text and hex. Normally this is no longer a problem, everything is entered as text. I would suggest trying a simple key to begin with to see if you can get that to work. Then try successively more complex ones. –  Julian Knight Jun 29 '12 at 6:43
    
My key was only 8 letters, so it is easy. Maybe the problem was in type of my key? I'd set it to WPA2-Personal. Maybe the issue with it - Ubuntu can't work with some Microsoft wifi profiles(protocols)? In past(when there was a password on my network) - I couldn't connect because network was inactive in the list of aviable networks. –  Nikolaj Jun 29 '12 at 11:19
    
WPA2-Personal should work. Did you have just standard characters in the key: upper and lower case a-z and numbers 0-9? Other things to try are using WPA instead of WPA2 and even trying WEP which, while no longer secure, is still better than nothing. –  Julian Knight Jun 29 '12 at 11:38
add comment

I am running Ubuntu 12.10 and at first I couldn't connect to my friends Windows 7 Ad Hoc with the default settings that Ubuntu used. Ubuntu detected that it was an Ad Hoc network and other settings. I could always "reach" the network, even with an WPA2 password, it only contained 8 characters. When I tried to connect it was trying for a while and then disconnected from it.

What I did was to use the standard settings, except I changed the bandwidth from Automatic to 2.4 GHz.

I also clicked out "Available for all users", but I have a hard time believing that that option should matter and I only have one account on the laptop.

Hope it helps you!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.