Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Toshiba L510 AND Ubuntu 12.04. I Cannot control brightness of my system using function keys. What could be the cause?

share|improve this question
1  
Does changing brightness any other way works? For, example, from the Power Management? Can you add the output of ls /sys/class/backlight/ to the question. –  mikewhatever Jun 27 '12 at 5:21
    
Looks like similar to this problem -- on the other hand, I found a related package in the repositories, toshset maybe it's worth checking out. redshift was also recommended –  medigeek Jun 27 '12 at 5:27
    
These function keys normally talk directly to BIOS, and are not visible to OS (Windows or Ubuntu). What key-combinations are you using? –  david6 Jun 27 '12 at 6:05
    
Possible duplicate of: askubuntu.com/questions/148365/… –  david6 Jun 27 '12 at 6:15
add comment

4 Answers

I just wanted to add, you can then set a keyboard shortcut to something like xbacklight -inc 10 to increase the brightness by 10%.

Unfortunately, you can't use Fn + Another Key since like he said, Fn is reserved for the BIOS. It's weird because my Fn + F7 works in turning off/on the screen, and Fn + F2 works in turning off (but not on) my wifi, but F5 and F6 do not adjust brightness... Hope someone can find a real fix soon.

share|improve this answer
add comment

Open a terminal using Ctrl+Alt+t and type sudo apt-get install xbacklight. That will install xbacklight Install xbacklight if it isn't already there (I can't remember whether it's a default package!).

Then type xbacklight -set x replacing the x with a number between 1 and 99 to set the percentage brightness for your screen backlight. You can actually set to 0 (and I do because I hate bright screens) but I understand that can cause problems on some displays so I don't recommend trying it.

share|improve this answer
add comment

Try adding acpi_backlight=vendor as a boot option. To do that, open a terminal window, and run

gksu gedit /etc/default/grub
Locate this line: GRUB_CMDLINE_LINUX="".

Edit it to look like this: GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

Save the file, then, in a terminal, run sudo update-grub.

Reboot, and check if the brightness keys work.

That worked for me!

Related link : Brightness function keys not working

share|improve this answer
add comment

I had the same problem on my Toshiba

I installed fnfxd package search synaptics Package Manger for it or

sudo apt-get install fnfxd

It solved my problem

share|improve this answer
    
This did not work for me –  Menachem Feb 28 at 0:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.