Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've reached a dead end in this matter & I was wondering if someone out there could help me out.

I located the grub file located in etc/default and edited it following reliable instructions. After I do & run the sudo update-grub & reboot, nothing changes & it stays the same.

I even have an application called "start-up manager" to simply adjust let's say the time-out, sadly that didn't work either.

Could someone help me out?

Note: I do have this thing called burg to have a GUI when booting, but even before I installed it the problem was there.

Here's my grub.cfg:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=" vga=775"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=800x600

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Files in etc/grub.d: 00_header, 05_debian_theme, 10_linux, 20_linux_xen, 20_memtest86+, 30_os-prober, 40_custom, 41_custom, readme

boot/grub/grub.cfg

http://pastebin.ubuntu.com/538608/

share|improve this question
    
What version of ubuntu you are using? –  karthick87 Dec 1 '10 at 8:55
    
I'm using Ubuntu 10.10 (kernel 2.6.35-22) –  Saifallah Dec 1 '10 at 9:36
    
Please provide a list of files in /etc/grub.d and post the contents of any "*_custom" file in that directory. Please also add the contents of /boot/grub/grub.cfg so we can see if the settings from /etc/default/grub you posted are reflected in grub's config file. (I guess it's ok to link to pastebin.ubuntu.com if things are too long ;)) –  htorque Dec 1 '10 at 10:28
    
Updated the question just now. Please check it. –  Saifallah Dec 1 '10 at 11:32
    
Hm, weird, you should have recovery entries with above config file. Did you manually edit the /boot/grub/grub.cfg file? Move it and re-run update-grub: sudo mv /boot/grub/grub.{cfg,back} ; sudo update-grub and look if there are recovery entries. (Note: if you don't want those, just uncomment #GRUB_DISABLE_LINUX_RECOVERY="true" in the /etc/default/grub file and run update-grub again.) Else, everything looks fine - your 1 second boot delay is there (although I don't know if that value isn't a bit too low). –  htorque Dec 1 '10 at 11:53
show 5 more comments

4 Answers

up vote 1 down vote accepted

Found the solution people. It seems that because of "burg" I must make changes to the burg file located in etc/default. And then run sudo update-burg.

share|improve this answer
add comment

Have you tried setting GRUB_HIDDEN_TIMEOUT_QUIET=true to false?

share|improve this answer
    
Yup, this worked once, then stopped again..I'm seriously sick with it =S –  Saifallah Dec 10 '10 at 14:03
add comment

You say that you have located the file grub in /etc/default but the file you have pasted above is /etc/grub/gruf.cfg.

Are you sure that you are editing the right file? /etc/grub/grub.cfg is an auto-generated file and it will update from configuration in other files whenever you run update-grub. You need to make changes into /etc/default/grub for them to take effect.

What I think is happening at the moment is that you change /etc/grub/grub.cfg and then you run update-grub, which reverts your changes, and then when you reboot you don't get what you want. Please try changing /etc/default/grub and then let us know what the output is.

share|improve this answer
    
What I posted is indeed the grub file located in /etc/default...but the "pastebin" link shows my /boot/grub/grub.cfg Read the question thoroughly. –  Saifallah Dec 3 '10 at 15:56
    
My bad but you have written "Here's my grub.cfg:" just above the pasted file –  binW Dec 3 '10 at 17:21
add comment

Here is the process step by step:

sudo -i                             gives root access

sudo gedit /etc/default/grub        gedit is editor 

GRUB_DEFAULT=X                      Change depending on order of boot eg 3
                                        where numbering starts with 0.

Save file and run the following from the terminal.

sudo update-grub                    updates file 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.