Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
  • Placed Ubuntu i386/32bit 12.04 LTS [DESKTOP] disc in the disc tray.
  • The disc loads fine.
  • Clicked install Ubuntu.
  • Without checking the download updates while installing or install this third-party software.
  • Clicked continue.

Mouse cursor turns to spinning circle and remains a spinning circle while the screen freezes its place at "Preparing to install Ubuntu".

  • I tried not checking any of the boxes and clicking continue.
  • I tried checking Download updates while installing.
  • I tried checking Install this third-party software.
  • I tried checking BOTH Download updates while installing AND Install
    this third-party software.

Does anyone else face this very same issue? Is there a workaround for this problem? Do I need to use a lower version of Ubuntu? If so, which version do you recommend for my system specifications?

My system meets the system requirements.

Here are my exact system specifications. (Custom modifications: 320GBx2 HDD && 256MB AGP GFX card && 1GBx2 RAM)

share|improve this question
up vote 1 down vote accepted

Your system may not support PAE, which the default Ubuntu 12.04 CDs now require

Were you able to successfully install previous Ubuntu releases, up to 11.10? Then this failure may be explained because your relatively old system does not support the PAE feature.

  • Ubuntu Desktop CDs only support PAE-enabled systems by default since 12.04

Solution: Please try installing either the 12.04 LTS Xubuntu Desktop or Lubuntu Desktop. Both of these still support non-PAE systems. Once installed, you can easily add the default Ubuntu desktop with sudo apt-get install ubuntu-desktop.

  • This answer (and others for that question) have more details on how to do the above, including a third method.

Technical note: While your processor (Athlon 3000+) has the PAE feature, it cannot be used because your motherboard probably does not support it; on these older systems, the memory controller was on the motherboard, while it is integrated on the CPU these days.

share|improve this answer
Thanks for the very informative explanation. I do not wish to use something other than the official Ubuntu software. I will probably just download the default Ubuntu desktop using sudo apt-get install ubuntu-desktop – Michael Ecklund Jul 9 '12 at 18:43

I will just presume (no details given) that you are attempting to install Ubuntu 12.04 desktop (32bit) on your PC, replacing any existing data or OS.

From you description, this could be a CD/DVD format issue, CD/DVD drive read issue, memory/timing hardware issues, or something else.

  • Try with another CD, or USB flash drive (to install from);

  • Try testing memory for 10+ minutes, using the test tools included in the LiveCD or Alternative Ubuntu installation disc; and/or

  • Verify that the CD/DVD drive can read another known, good disk.

share|improve this answer
I have tried Memorex discs (which I heard are garbage and should never be used), but I also tried Imation. Same issue persists. Tested the memory, no problem. I was able to install the server disc without problems. I will probably just end up downloading the desktop through the online repository. – Michael Ecklund Jul 9 '12 at 18:38
I would recommend a 2GB (or larger) USB drive, to install from. It is 2-3 faster to install, no media seek or read delays. – david6 Jul 10 '12 at 8:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.