Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed the newest version of ALSA and my NVIDIA device showed up in the gnome-volume-control. I can't actually get any sound on the TV though. When searching around it seems the solution for 95% of people is to "unmute the device". My device is not muted or disabled:

Sound Preferences - Hardware

Sound Preferences - Output

My TV is not muted and it gets sound perfectly from my Xbox. Also, switching to "Internal Audio Analog Stereo" or "Logitech G930 Headset Analog Stereo" works and gives me sound. Additionally when booting to Windows the HDMI audio works fine. I don't know what to make of the AlsaMixer though:

AlsaMixer - HDA NVidia

Why can't I get any sound on my TV through NVidia GTX580? Here's my alsainfo output: http://www.alsa-project.org/db/?f=e41666ca9765badc84098ee4bc18c2c38f4bd856

share|improve this question
    
Have you tried unmuting the other S/PDIF channels in alsamixer? –  Oli Jun 26 '12 at 22:24
    
@Oli I don't know how –  Hubro Jun 27 '12 at 8:34
    
Press left and right to change selected channel, m to toggle mute. –  Oli Jun 27 '12 at 10:04
    
@Oli: Unfortunately un-muting didn't have any effect. They are now all at 0 and I can't turn them up –  Hubro Jul 7 '12 at 20:15

1 Answer 1

Have you tried to "mute"/disable your other sound drivers, leaving only the HDMI output left? Ubuntu has had problems in the past when it came to detecting specific audio drivers to use (And by that I mean the ones you want active)

share|improve this answer
    
Disabled all other audio devices so that HDMI was the only remaining option in the Output tab - didn't make any difference –  Hubro Jun 26 '12 at 22:33
    
@Codemonkey, ok, have you tried disabling pulse audio using the command "sudo killall pulseaudio"? –  Compt Jun 26 '12 at 23:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.