Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Partly it is a Curious question . ( Pretty stupid though)

I am using Ubuntu 12.04 64-Bit system with Unity as DE.

I was doing a routine to free -up some memory space by manual deletion of unwanted files (mostly songs and videos) and thereby right-clicking to verify for freed space.

But doing a right-Click Properties option in Root File system shows tremendous amount of Contents Memory 140.8 TB as follows

enter image description here

My Ubuntu is installed on 50 GB partition with ext4 as format having only / and swap as OS installation in dual boot with Windows 7 .My Internal Hard Disk is 1TB only.

So what exactly is it showing and why is it pointing such huge memory. What are the reasons for that huge Memory show.

P.S.: Must be related to some Linux OS File System based Concept i haven't yet learned or looked into.

O/P of df -h

Filesystem      Size  Used Avail Use% Mounted on
/dev/sda8        49G   12G   36G  25% /
udev            1.9G  4.0K  1.9G   1% /dev
tmpfs           773M  860K  772M   1% /run
none            5.0M     0  5.0M   0% /run/lock
none            1.9G  784K  1.9G   1% /run/shm
share|improve this question

2 Answers 2

up vote 2 down vote accepted

It is a known bug gnome. It doesn't only count files in the / filesystem, it also counts files mounted in other filesystems, including /proc, which contains a virtual file that represents all ram, which amounts to 128 TB on amd64.

share|improve this answer
    
Thanks for Bug Report Link, so now should i also report it , if necessary .Also it says 128 TB, but i have addition of extra 12 TB's to it. –  atenz Jun 27 '12 at 5:52

This is likely a bug in either Nautilus or one of the libraries you are using, and it is calculating space used by some files several times due to recursive symbolic links or something, and including all the partitions you have mounted, perhaps including remote mounts as well.

What does running df -h in a terminal tell you?

share|improve this answer
    
Thanks for replying .Even i had the doubt of Its showing contents of mounted partitions (inodes/ directory) , so i tried it as standalone [but found same result] , and for network related , no my PC is not connected to any Remote network howsoever. Even if i just imagine it is somehow connected to other remote networks which will be locally , isn't 140 TB too much for that too .Probably a bug, i need to find out. –  atenz Jun 26 '12 at 19:51
    
Yea i forgot ,but now added the o/p of df -h .Thanks. –  atenz Jun 26 '12 at 20:17
2  
Well, it is definitely traversing mounted partitions here, as it was over 100GB for me, and my / is only using 22GB. I didn't let it finish though, as it was killing my CPU going over everything. 140TB does seem like a lot, indeed, which makes me think it's reading the same files many times, due to recursive symlinks. –  dobey Jun 26 '12 at 20:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.