Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try to add a repository via the command line, I get the following error message:

Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 125, in <module>
    ppa_info = get_ppa_info_from_lp(user, ppa_name)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp
    curl.perform()
pycurl.error: (60, 'server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none')

Is there a way to remedy this situation?

share|improve this question
    
Is your network using a proxy server? –  Bruno Pereira Jun 26 '12 at 17:19
    
Not to my knowledge –  Kristopher Arens Jun 26 '12 at 17:25
2  
This is rather an error about Certificate Verification than Network Connectivity. Does the mentioned file /etc/ssl/certs/ca-certificates.crt exist? –  mweinelt Jun 26 '12 at 18:30
    
Yes, the file does exist –  Kristopher Arens Jun 26 '12 at 18:53
    
Can people experiencing this problem connect to launchpad.net/api/1.0/~jsjgruber/+archive/ppa with Firefox and get a secure connection (locked padlock on the URL line)? What version of the ca-certificates package do you have (dpkg -s ca-certificates ? Output of ls -ltr /usr/share/ca-certificates/mozilla/Go* ? Does it help to upgrade the ca-certificates package and run sudo update-ca-certificates ? –  John S Gruber Aug 5 '12 at 20:35

4 Answers 4

You need to make sure your date is set, the certificates have a valid from date and if your system date is 01-01-1970, all certificates will fail.

Use something like

date -s "Oct 9 05:16:00 UTC 2012"

then try again with add-apt-repository.

share|improve this answer

This kind of problem can be caused when there is something wrong with the central authority certificates on your system. These certificates are used to establish a chain of trust from someone Ubuntu or Mozilla trusts to a particular site when https: is used. The chain of trust starts with certificates installed as part of your Ubuntu system.

The problem might ordinarily manifest itself when you use a web browser to make a secure connection to a web site. In this case add-apt-repository is using the https: protocol to securily add a repository and its authentication keys. The current Ubuntu ppa repositories require a chain of trust from MakeDaddy.com to Canonical. If you use Firefox to browse to the same repositories using https: you will probably see an error rather than a closed padlock for the site, and clicking that will provide error messages indicating that the chain of trust cannot be determined.

Enter the following to reinstall the central authority certificates:

sudo apt-get install --reinstall ca-certificates

Another helpful command for this:

sudo update-ca-certificates
share|improve this answer

I used to this get this error when i used the command in the terminal, but when i added it from gui for the software sources it was added successfully.Try using the gui...

press start button and type software sources and press enter

go to other software tab and click add button in the bottom

type the apt line of the repository and click add source and wait for a moment

go to terminal and type

    sudo apt-get update

and that should be all...

share|improve this answer

http://www.iheartubuntu.com/2012/11/ppa-for-netflix-desktop-app.html

NOTE #1 If you had previously tried to install the Netflix Desktop App via our terminal commands from the earlier post, we recommend running the line below in a terminal to clear out any unexpected errors BEFORE trying to install the Netflix Desktop app via the PPA method...

rm -Rf ~/.netflix-desktop

Worked like a charm!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.