Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 12.04 Precise Pangolin, with Gnome 3, and it looks like my computer has some strange ideas when it comes to accented keys.

Without changing any of the settings, the results I get are strange and inconsistent:

AltGr + a = æ
AltGr + e = e
AltGr + u = ↓
AltGr + 2 = ²
AltGr + n = n
AltGr + g = ŋ
AltGr + Shift + e = E
AltGr + Shift + u = ↑
AltGr + [ then e = ë
AltGr + [ then o/i/u/a = nothing
- These are the methods I've tried to use to get umlauted characters
AltGr + 2 = ²
AltGr + Shift + 2 = ⅛
AltGr + Shift + 2 + o = ⅛Ø
AltGr + 2 + o = ²ø

When I follow the instructions here https://help.ubuntu.com/11.04/ubuntu-help/tips-specialchars.html, and I set the compose key to be Right Alt, AltGr (which is the alt key to the right of the space bar) turns into a fully working regular alt key, and I cannot enter any special characters. Changing the "Key to choose third level" has no effect.

I would prefer to have the fully working accented character system, but I'd settle for just being able to get ß and the vowels with umlauts.

Thanks

share|improve this question

1 Answer 1

Recently 12.04 introduced a bug in keyboard handling. The workaround is to use the following code in a terminal:

setxkbmap "en","fr"

where en and fr represent the keyboard layouts you use.

One step further is to run this command on startup by clicking the top right cog wheel and choose startup applications.

share|improve this answer
    
I get "Error loading new keyboard description". Looking into keyboard layouts I only have the English (UK) option (I live in the UK) –  Peter Jun 26 '12 at 19:12
    
The above is just an example. If you only have english try setxkeymap uk –  To Do Jun 27 '12 at 20:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.