Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I thought I asked about this before, but I can't find it.

I have a computer called "Mythbuntu" that is on my LAN. When I first boot the computer I work from, I see an entry for "Mythbuntu" in my "Places" menu, like so:

Mythbuntu menu one

When I click on it, I get this error message:

Mythbuntu error

However, once I dismiss it, there are two entries for my Mythbuntu computer in the "Places" menu, where the bottom one is the one that works:

Mythbuntu menu two

This is my entry in /etc/fstab for the Mythbuntu computer, which I adapted from some tutorial somewhere on the net:

[email protected]:/home/mythbuntu    /home/dave/Mythbuntu    fuse    comment=sshfs,user,noauto,transform_symlinks

How can I set it up so that my Mythbuntu computer mounts on boot without having any error messages or having to click on a menu entry to activate it?

share|improve this question

1 Answer 1

up vote 2 down vote accepted
  1. Change noauto to auto -- right now you've explicitly disabled auto-mount!
    • and add Batchmode=yes
  2. Mounting sshfs via /etc/fstab may fail if no network connection exists at that point.
    • If you have that problem, this post details a fairly concise way of setting up ifup/ifdown scripts that will mount/unmount sshfs upon network link up/down.
share|improve this answer
    
Thank you for responding. Unfortunately, when I make the changes you suggest, particularly changing noauto to auto, it results in an error message on the splash screen on boot. It says "There was an error mounting /home/mythbuntu, press S to skip or M to manually edit" (or something like that). The Mythbuntu machine is definitely available on the network, so maybe there's something else I need to do? –  Dave M G Jun 26 '12 at 15:07
    
The problem is that at that point in the boot process, the network is not available on your machine. Please look at the link I posted and see if that works (up/down scripts) –  izx Jun 26 '12 at 15:09
    
Yep, I looked at the link and I set up the up down scripts, but I still get the error message. Actually, I just confirmed that even though I press "S" to skip, the Mythbuntu machine does actually successfully mount. So that's good. It would just be perfect if there was no error message along the way. –  Dave M G Jun 26 '12 at 15:57
    
Since this answer resolved the initial issue, I've marked this as correct, but I've started another question about the problem in the boot process: askubuntu.com/q/157859/17041 –  Dave M G Jun 30 '12 at 3:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.