Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had previously installed an Ubuntu One client as a test on a Windows XP machine. Now I wanted to change the account for the client to a production one but had problems changing the email address so decided to do a reinstall.

  • Ran uninstall.
  • Downloaded ubuntuone-3.0.2-windows-installer.exe.
  • It downloads, goes through the unpacking/install – strangely some of the messages say updating as if it was replacing something that was already there.
  • I do not get the setup/signin screen. There is no ubuntu% processes running. The Program files/ubuntuone directory exists with data and dist folders.
  • The U icon is on the desktop – pointing at ubuntuone/dist/ubuntuone-control-panel-qt.exe but this does not run.

Ran uninstall again, deleted Program files/ubuntuone directory, removed any ubuntu entries for registry, remove all 'application data' ubuntu files and directories, rebooted. Downloaded install again - exactly the same as above.

From the deleted registry entries the previous successful install was 2.0.3, I therefore re-installed 2.0.3 and everything is working again. Not sure if this is a problem with this computer or a more general problem with 3.0.2 and XP?

share|improve this question
    
what about %appdata% directory? look for any entry –  Web-E Jun 26 '12 at 9:14
    
@Web-E - thanks, have also tried deleting 'application data' files and directories - no difference. –  user73303 Jun 26 '12 at 10:04
    
@user73303 Could you test the workaround from the answer and indicate if worked for you? –  lgarzo Jun 29 '12 at 10:16
add comment

1 Answer 1

Known bug with 3.0.2 windows installer. https://launchpad.net/bugs/1017019

Workaround for the problem from the same article:

Delete mswsock.dll and powrprof.dll from UbuntuOne installation directory/dist subdirectory (e.g. C:\Program Files\ubuntuone\dist). After this the native libraries will be used and the application will be able to start.

The reason is:

dist/mswsock.dll and dist/powrprof.dll [...] were taken from a Windows7 system

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.