Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install NetBeans IDE on my Ubuntu 12.04. However no matter how many time i install/resintall it (from Software Center), it still gives this strange problem:

After I complete the installation and try to launch it, Netbeans first displays the initialization window. After it completes, the window disappears and nothing happens. Then after a while Netbeans seemingly restarts and then again shows the initialization window.

This goes on in an infinitesimal cycle and I'm ultimately forced to restart my computer and uninstall NetBeans.

Why could this be happening? I really need NetBeans as it is a very good IDE.

share|improve this question
    
Have you tried installing from terminal? –  Mitch Jun 26 '12 at 7:20
    
Good idea. I'll try and post the result. –  upapilot Jun 26 '12 at 7:22
    
Tried it with terminal. Same result. –  upapilot Jun 26 '12 at 7:46
add comment

2 Answers

up vote 0 down vote accepted

Hi have you tried installing it manually I usually install Netbeans on my different work stations manually to take advantage of the latest releases.

I have also include a link to a video below that I used although it's a bit old it's still very good.

Video

share|improve this answer
    
This worked, thanks! –  upapilot Jun 26 '12 at 14:32
    
Cool, I'm a big fan of Netbeans so I'm glad you got it working! –  CoalaWeb Jun 26 '12 at 18:02
add comment

Make sure that you are using the official JDK, provided by Oracle, not the OpenJDK, which comes with Ubuntu by default. Eclipse does not work very well with the OpenJDK - I would suspect this might be the case with Netbeans as well. To check your Java version, open the terminal and try this:

java -version

You should see something like this:

java version "1.7.0_03"
Java(TM) SE Runtime Environment (build 1.7.0_03-b04)
Java HotSpot(TM) 64-Bit Server VM (build 22.1-b02, mixed mode)

instead of this:

java version "1.7.0_03"
OpenJDK Runtime Environment (IcedTea7 2.1.1pre) (7~u3-2.1.1~pre1-1ubuntu3)
OpenJDK 64-Bit Server VM (build 22.0-b10, mixed mode)
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.