Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've had this issues across multiple machines and multiple versions of Ubuntu desktop (all 10.04 or later). Usually it happens with an old laptop I've put Ubuntu on but now it's happening on my primary dev machine (a quad-core PC recently upgraded to Ubuntu 12.04 desktop). The problem is this - I can connect to the machine and login with the password, the initial screen looks fine but never refreshes. I can see the monitor for the machine across the room and can see the mouse move and the menus pop up but the image of the screen on the PC in front me running the VNC viewer never updates. So the mouse and keyboard commands are working.

  • Ubuntu 12.04 Desktop
  • Ultra VNC Viewer (also seen with RealVNC's free VNC viewer)
  • Desktop Sharing Static IP on eth0; Dynamic ID on eth1

I think it is an Ubuntu config issue because this PC used to work just fine with 9.04, 10.04, and 11.10 (over the past couple of years). I've also had a couple of laptops that used to have this issue with older Ubuntu's but don't with 12.04.

Additional info:

The Win7 PC I'm trying to use to control the Ubuntu PC is connected via 2 DLink 8-port gigabit routers. The Ubuntu laptop I usually control via VNC is typically only connected to the network via wireless. The screen refresh is choppy but usable. I've repeated the issue on a Win7 laptop which was connected via ethernet and wireless.

share|improve this question
Switch to Unity 2D for now There's a fix for 3d, someone will be along shortly. – izx Jun 26 '12 at 4:53
I'm not that big a fan of Unity. If Unity is the the issue can I fix it by installing/using Gnome or one of the other desktops? – user73279 Jun 26 '12 at 6:04
Is this a bug to be filed against Unity or VNC? Bugs are usually closed as off-topic but I'm glad you sorted it out for now. If this is a known bug it is best to flag the question. – Tom Brossman Jul 2 '12 at 22:13
No idea really. Everything works well with the VNC using Unity2D. It worked OK (see the answer below regarding the moving windows to refresh) on my laptop which was running Gnome. Running KDE Plasma did nothing to change the problem. Now I run Unity2D on both the PC and laptop I've mentioned and the only issue appears to be having a VNC screen up to both of them but I haven't thoroughly tested that (other priorities right now). – user73279 Jul 6 '12 at 19:52
possible duplicate of VNC session very slow in 12.04 compared to older versions – Eliah Kagan Aug 13 '12 at 2:33

I was having same problem, Searched a bit and found this solution

VNC session very slow in 12.04 compared to older versions

Running the mentioned command solved the purpose Thanks

share|improve this answer
Thanks for the solution! – antivirtel Sep 23 '12 at 10:56

Remoting into ubuntu 14.04 LTS from ubuntu 12.04 LTS using either Remmina Remote Desktop or Gtk VNC Viewer did not work. The remote session did not update the screen. The command, gsettings set org.gnome.Vino disable-xdamage true did not work. Unfortunately I did not try logging in to 14.04 in 2D mode before installing 12.04 LTS. Remoting into ubuntu 12.04 LTS from ubuntu 12.04 LTS did not work either. Setting disable-xdamage true did not work. Logging into 12.04 using 2D and then remoting in did work. Then restarting and logging into 3D in 12.04 worked.

I am currently logging into 12.04 in 3D mode, then remoting into 12.04 from 12.04 using Remmina Remote Desktop. On the remote machine the command "gsettings get org.gnome.Vino disable-xdamage returns false. I believe starting the initial session in 2D mode at least one time was the key.

Note I had to submit this as an answer because I don't have enough points to comment at

share|improve this answer
up vote 1 down vote accepted


I would have clicked on your answer except you left it as a comment. So I'm adding this as an answer so it can be closed.

I switched to Unity 2D and that fixed my issues with the PC. I also switched to Unity 2D on my laptop that worked (but you had to move windows around the desktop to get that part of the desktop to refresh). It is still choppy but far less problematic.

FYI, I tried KDE Plasma first. I've loved the look but it was no help in fixing the screen refresh issues.

share|improve this answer
Thanks, glad things worked out for you! – izx Jul 7 '12 at 8:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.