Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can not figure out what I am doing wrong. The package builds ok with quickly package, I could submit it, but I can not update my ppa. Here is what I got:


desgua@desguai7:~/quickly/sbk$ quickly share --ppa sbk
Get Launchpad Settings
Launchpad connection is ok
..........An error has occurred when creating debian packaging
ERROR: can't create or update ubuntu package
ERROR: share command failed
Aborting

Edit

The name of my ppa was wrong, but even using ppa:desgua/sbk still doesn't work:

desgua@desguai7:~/quickly/sbk$ quickly share --ppa ppa:desgua/sbk
Get Launchpad Settings
Traceback (most recent call last):
  File "/usr/share/quickly/templates/ubuntu-application/share.py", line 101, in 
    launchpad = launchpadaccess.initialize_lpi()
  File "/usr/lib/python2.7/dist-packages/quickly/launchpadaccess.py", line 91, in initialize_lpi
    allow_access_levels=["WRITE_PRIVATE"])
  File "/usr/lib/python2.7/dist-packages/launchpadlib/launchpad.py", line 539, in login_with
    credential_save_failed, version)
  File "/usr/lib/python2.7/dist-packages/launchpadlib/launchpad.py", line 359, in _authorize_token_and_login
    service_root, cache, timeout, proxy_info, version)
  File "/usr/lib/python2.7/dist-packages/launchpadlib/launchpad.py", line 198, in __init__
    credentials, service_root, cache, timeout, proxy_info, version)
  File "/usr/lib/python2.7/dist-packages/lazr/restfulclient/resource.py", line 460, in __init__
    self._wadl = self._browser.get_wadl_application(self._root_uri)
  File "/usr/lib/python2.7/dist-packages/lazr/restfulclient/_browser.py", line 299, in get_wadl_application
    response, content = self._request(url, media_type=wadl_type)
  File "/usr/lib/python2.7/dist-packages/lazr/restfulclient/_browser.py", line 242, in _request
    str(url), method=method, body=data, headers=headers)
  File "/usr/lib/python2.7/dist-packages/lazr/restfulclient/_browser.py", line 211, in _request_and_retry
    url, method=method, body=body, headers=headers)
  File "/usr/lib/python2.7/dist-packages/httplib2/__init__.py", line 1414, in request
    (response, new_content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/usr/lib/python2.7/dist-packages/launchpadlib/launchpad.py", line 126, in _request
    LaunchpadOAuthAwareHttp, self)._request(*args)
  File "/usr/lib/python2.7/dist-packages/lazr/restfulclient/_browser.py", line 130, in _request
    redirections, cachekey)
  File "/usr/lib/python2.7/dist-packages/httplib2/__init__.py", line 1196, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/python2.7/dist-packages/httplib2/__init__.py", line 1138, in _conn_request
    raise ServerNotFoundError("Unable to find the server at %s" % conn.host)
httplib2.ServerNotFoundError: Unable to find the server at api.launchpad.net
ERROR: share command failed
Aborting

Any ideas? How could I troubleshot this error?

share|improve this question
add comment

2 Answers

sbk is not a PPA. Something like ppa:robinj/gtkreddit is.

I'm guessing this is yours; ppa:desgua/sbk.

I don't think this is the current problem though. Try quickly package first. Does it succeed?

share|improve this answer
    
Thank you very much RobinJ. Yes quickly package succeeds. You are rigth, looking at launchpad.net/~desgua/+archive/sbk I think the ppa is desgua/sbk but the command still doesn't work. At least I am getting some errors now that I can search for. –  desgua Jun 26 '12 at 22:28
    
httplib2.ServerNotFoundError: Unable to find the server at api.launchpad.net Check your connection? I don't know it just seems to feel to connect to Launchpad. Are you using a proxy or anything? –  RobinJ Jun 27 '12 at 8:37
    
The connection is ok. I'm in another computer now and the command quickly share --ppa ppa:desgua/sbk complains about not finding the ppa, but the command quickly share --ppa desgua/sbk says An error has occurred when creating debian packaging. –  desgua Jun 27 '12 at 17:47
    
quickly package –  RobinJ Jun 27 '12 at 18:03
    
quickly package runs successfully and the deb is working ok. –  desgua Jun 27 '12 at 20:53
show 4 more comments
up vote 2 down vote accepted

To troubleshot it I add --verbose: quickly share --verbose --ppa desgua/sbk.

Also a gpg and a rsa key are needed and must be published in the launchpad.

This command may have helped: python setup.py build

Also I have to check the file "name_version_source.changes" and the file "./sbk/debian/changelog" and make sure that the "Changed-By: Andre Desgualdo Pereira " is the same as the output of "gpg -K"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.