Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I change from Unity 2D to 3D on ubuntu 12.04?

I am running an AMD NX2100 with 512k memory and NVIDIA FX5200

I've tried numerous cures/downloads/fixes noted within Ask Ubuntu, but when ever I run MyUnity I will always get this same message:

Your Ubuntu 12.04 is running in 2D mode. Many features will not be available.

Most everything within the MyUnity menu is grayed out.

I am new to Ubuntu and have been working on this for more than two weeks to no avail.

share|improve this question
perhaps the output of the unity-support-test (…) would help here together with the nvidia driver you may nor may not be using from the Additional Drivers window - please add any replies to your Question. Thanks. – fossfreedom Jun 25 '12 at 22:29
Old question, I know..but...I have the very same card and I think the actual culprit must be a severe bug in the nouveau driver, because Firefox has the 5200 blacklisted as well for (almost) any kind of H/W acceleration. And that is for a reason, because once I try to enable it by force, I get "graphics confetti", which is so extreme that I have to hand-edit prefs.js to be able to work with Firefox the usual way again. – syntaxerror Feb 12 at 0:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.