Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Trying to run FlightGear 2.6 from PlayDeb on Ubuntu 12.04 LTS 32bits, I get this error every time :

fgfs: symbol lookup error: /usr/lib/libsgtsync.so.2.6.0: undefined symbol: svn_subr_version

Thanks for help.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

To solve my problem :

  • I removed the PlayDeb repository :
    sudo add-apt-repository -r "deb http://archive.getdeb.net/ubuntu precise-getdeb games".
  • Then, I updated the sources :
    sudo apt-get update.
  • Then I removed all fgfs files :
    sudo apt-get remove flightgear fgfs*.
  • Then I reinstalled FlightGear 2.4 :
    sudo apt-get install flightgear.
  • Then I added the PlayDeb repository again :
    sudo add-apt-repository "deb http://archive.getdeb.net/ubuntu precise-getdeb games".
  • And finally, I upgraded :
    sudo apt-get update && sudo apt-get dist-upgrade
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.