Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this desktop:

  • i7 2600
  • 8 GB RAM ddr3
  • Board Intel dh61ww
  • Geforce Nvidia GT520-cn 2Gb ddr3

I just installed Ubuntu 12.04 64-bit (kernel 3.2.0-23-generic). I want to setup two Samsung 22" LED monitors and get my video card drivers working.

I downloaded and installed Nvidia driver 295.59. I tried the following with that driver and also with 302.17.

I ran these commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install build-essential linux-headers-$(uname -r),
sudo apt-get remove --purge nvidia*,
sudo apt-get remove --purge xserver-xorg-video-nouveau
vim /etc/modprobe.d/blacklist.conf

In the vim text editor, I added the following lines to blacklist.conf:

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

Then I ran these commands:

sh NVIDIA.run
sudo service lightdm start

I rebooted, and after rebooting ran:

nvidia-xorgconf

After reboot I got a screen resolution of 800x600. I ran nvidia-settings and it said:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

I changed xorg.conf slightly to set up a resolution to work property.

I don't have any image on my monitor and I dont have any option in the Nvidia X server settings.

$ lspci | grep VGA 
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 520] (rev a1)

$ egrep -i 'glx|nvidia' /var/log/Xorg.0.log

[    12.005] (II) LoadModule: "glx"
[    12.005] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    12.575] (II) Module glx: vendor="NVIDIA Corporation"
[    12.585] (II) NVIDIA GLX Module  302.17  Tue Jun 12 16:22:45 PDT 2012
[    12.585] (II) Loading extension GLX

[    13.037] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

[    13.044] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event10)
[    13.044] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event9)

$ glxinfo | grep direct 
Xlib:  extension "GLX" missing on display ":0.0". Error: couldn't find RGB GLX visual or fbconfig
share|improve this question
    
My question here might help‌​. I had the same problem with an Nvidia GeForce GT 520M and Ubuntu 12.04. I backed up my data, did a fresh install, then purged NVIDIA, and it's working fine now, although it's not actually using the NVIDIA drivers - not sure if it's using the OSS ones (Nouveau?) or not. –  Don Jun 26 '12 at 12:25
    
Are you able to reproduce this? –  Braiam Feb 23 at 0:03
add comment

closed as off-topic by Braiam, guntbert, Eric Carvalho, Avinash Raj, Minato Namikaze Feb 24 at 4:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – guntbert, Eric Carvalho, Avinash Raj, Minato Namikaze
If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers

If you go to system preferences -> additional drivers. Click the recommended NviDia driver. Thats all i had to do. Hopefully it helps.

share|improve this answer
1  
And if nothing shows up in "additional drivers", check to make sure you have the "restricted" repository enabled. –  neon_overload Jun 26 '12 at 6:39
add comment

I've got the Gigabyte Geforce GT 520.

On my Debian Wheezy system fresh installed today, all I did was the following commands as root

sudo apt-get -y install nvidia-glx nvidia-xconfig
sudo nvidia-xconfig

and then rebooted and Gnome 3 worked fine and games worked fine.

share|improve this answer
add comment

I have just updated my video card from an internal Intel to an Nvidia GT520. After rebooting, the screen was jammed and not responding. Initially I thought that the video card was defective, but it was recognised in the BIOS correctly.

So, I rebooted with the Shift key pressed, edited the boot loader (by pressing e), changed quiet splash to text and pressed F10.

After that I logged in as my user and ran the following commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nvidia-current
sudo shutdown -r now

After I rebooted, everything worked fine and all resolutions were available.

share|improve this answer
add comment

goseeped:

Have you installed the extra drivers? You can do that in the softwarecenter (Search "Additional drivers" and "binary nvidia driver". Or do it with:

sudo apt-get install jockey-gtk, nvidia-current

After that, you can go to system preferences -> additional drivers

Works perfekt for me... and i use 2 monitors too.

Good Luck

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.