Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Correcting this question, I've realised that I was - and still am - unable to sync folders with ubuntu one, because pcmanfm is still my default LXDE file manager, despite the fact that I've changed the panel settings as I should have done (at least I think so) and replaced the entry "pcmanfm %s" with "nautilus". Yet, how can I actually change it?

Kind regards, schlossblick

share|improve this question

1 Answer 1

up vote 11 down vote accepted

When you open file manager you get

enter image description here Now go to Menu --> Accessories --> File Manager --> right click, and choose properties

enter image description here

Change pcmafm to nautilus and you will get

enter image description here

However that only changes the application that will be opened by the shortcut "file manager". It does not make nautilus the "default file manager" in the proper sense: Opening a folder on the desktop, or opening a file location from an application would not open nautilus, but still pcmanfm.

Note: I will be adding information on how to make this change permanent in the next couple of days.

Note: This is my own personal opinion. I've tried these steps on my machine, and they worked. But I didn't like the outcome.

Change the contents of /etc/xdg/lxsession/LXDE/autostart as shown below.

From

@xscreensaver -no-splash
@setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,ar
@lxpanel --profile LXDE
@pcmanfm --desktop --profile LXDE 
@/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

To

@xscreensaver -no-splash
@setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,ar
@lxpanel --profile LXDE
@/usr/bin/nautilus -n
@/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

Also you can take a look at https://help.ubuntu.com/community/DefaultFileManager to see if it might help.

Edit:

In Ubuntu 14.04 here's what I did. I did a fresh installation of Ubuntu 14.04, and then installed LXDE. Once that was done, I set nautilus as a default file manager using the following command:

xdg-mime default nautilus.desktop inode/directory application/x-gnome-saved-search

and then I checked the current default file manager using the command below:

xdg-mime query default inode/directory

and it showed Nautilus as the default. See image below.

enter image description here

share|improve this answer
    
Hello Mitch,thank you SO MUCH! That's exactly the answer I looked for, described in a way I - having contact to computers only as a user without any programming knowledge - can understand it. –  schlossblick Jun 25 '12 at 19:07
    
Can you please elaborate on "But I didn't like the outcome."? –  user25656 Mar 25 '13 at 11:16
    
For strictly personal issue, it's not what I expected. But that's my opinion as I said. –  Mitch Mar 25 '13 at 11:25
    
I just asked because I'm thinking of using Thunar in place of PCManFM. –  user25656 Mar 25 '13 at 11:27
    
OK, but give Nautilus a shot as well. –  Mitch Mar 25 '13 at 11:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.